summaryrefslogtreecommitdiff
path: root/games-emulation/dolphin/dolphin-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dolphin/dolphin-9999.ebuild')
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild28
1 files changed, 17 insertions, 11 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index 55392d47b0fd..56655d4613a0 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -1,19 +1,21 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PLOCALES="ar ca cs da de el en es fa fr hr hu it ja ko ms nb nl pl pt pt_BR ro ru sr sv tr zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit cmake-utils desktop gnome2-utils l10n pax-utils
+inherit cmake desktop xdg-utils l10n pax-utils
if [[ ${PV} == *9999 ]]
then
EGIT_REPO_URI="https://github.com/dolphin-emu/dolphin"
inherit git-r3
else
- SRC_URI="https://github.com/${PN}-emu/${PN}/archive/${PV}.zip -> ${P}.zip"
+ inherit vcs-snapshot
+ commit=0dbe8fb2eaa608a6540df3d269648a596c29cf4b
+ SRC_URI="https://github.com/dolphin-emu/dolphin/archive/${commit}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
@@ -59,9 +61,8 @@ RDEPEND="
systemd? ( sys-apps/systemd:0= )
upnp? ( net-libs/miniupnpc )
"
-DEPEND="${RDEPEND}
- app-arch/zip
- media-libs/freetype
+DEPEND="${RDEPEND}"
+BDEPEND="
sys-devel/gettext
virtual/pkgconfig"
@@ -71,7 +72,7 @@ RDEPEND="${RDEPEND}
media-libs/vulkan-loader"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# Remove all the bundled libraries that support system-installed
# preference. See CMakeLists.txt for conditional 'add_subdirectory' calls.
@@ -146,13 +147,18 @@ src_configure() {
-DUSE_DISCORD_PRESENCE=$(usex discord-presence)
-DUSE_SHARED_ENET=ON
-DUSE_UPNP=$(usex upnp)
+
+ # Undo cmake-utils.eclass's defaults.
+ # All dolphin's libraries are private
+ # and rely on circular dependency resolution.
+ -DBUILD_SHARED_LIBS=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc Readme.md
if use doc; then
@@ -167,9 +173,9 @@ src_install() {
pkg_postinst() {
# Add pax markings for hardened systems
pax-mark -m "${EPREFIX}"/usr/games/bin/"${PN}"-emu
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}