summaryrefslogtreecommitdiff
path: root/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild')
-rw-r--r--games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild30
1 files changed, 20 insertions, 10 deletions
diff --git a/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild b/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
index 5d9acdc094b9..3d541bd2cb8c 100644
--- a/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
+++ b/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit autotools
DESCRIPTION="A Linux/SDL-Port of the famous DGen MegaDrive/Genesis-Emulator"
HOMEPAGE="http://dgen.sourceforge.net/"
@@ -15,13 +17,20 @@ IUSE="joystick opengl"
RDEPEND="
media-libs/libsdl[joystick?,opengl?]
app-arch/libarchive
- opengl? ( virtual/opengl )
-"
-DEPEND="${RDEPEND}
- x86? ( dev-lang/nasm )
-"
-
-PATCHES=( "${FILESDIR}"/${P}-joystick.patch )
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}"
+BDEPEND="x86? ( dev-lang/nasm )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-joystick.patch
+ "${FILESDIR}"/${P}-AM_PROG_AR.patch
+ "${FILESDIR}"/${P}-clang-c++11.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
econf \
@@ -36,5 +45,6 @@ src_compile() {
}
src_install() {
- DOCS="AUTHORS ChangeLog README sample.dgenrc" default
+ default
+ dodoc sample.dgenrc
}