summaryrefslogtreecommitdiff
path: root/games-emulation/desmume/desmume-0.9.11-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/desmume/desmume-0.9.11-r1.ebuild')
-rw-r--r--games-emulation/desmume/desmume-0.9.11-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-emulation/desmume/desmume-0.9.11-r1.ebuild b/games-emulation/desmume/desmume-0.9.11-r1.ebuild
new file mode 100644
index 000000000000..e98e0846012b
--- /dev/null
+++ b/games-emulation/desmume/desmume-0.9.11-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xdg
+
+DESCRIPTION="Nintendo DS emulator"
+HOMEPAGE="http://desmume.org/"
+SRC_URI="mirror://sourceforge/desmume/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/zziplib
+ gnome-base/libglade
+ media-libs/libsdl[joystick,opengl,video]
+ sys-libs/zlib
+ virtual/opengl
+ x11-libs/agg
+ >=x11-libs/gtk+-2.8.0:2
+ x11-libs/gtkglext"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README README.LIN )
+
+# fix QA compiler warning, see
+# https://sourceforge.net/p/desmume/patches/172/
+PATCHES=(
+ "${FILESDIR}/${P}-fix-pointer-conversion-warning.diff"
+ "${FILESDIR}/${P}-gcc6.patch"
+ "${FILESDIR}/${P}-gcc7.patch"
+)