summaryrefslogtreecommitdiff
path: root/games-emulation/desmume/desmume-0.9.11-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/desmume/desmume-0.9.11-r1.ebuild')
-rw-r--r--games-emulation/desmume/desmume-0.9.11-r1.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/games-emulation/desmume/desmume-0.9.11-r1.ebuild b/games-emulation/desmume/desmume-0.9.11-r1.ebuild
index cddcc940a314..e98e0846012b 100644
--- a/games-emulation/desmume/desmume-0.9.11-r1.ebuild
+++ b/games-emulation/desmume/desmume-0.9.11-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit xdg
+
DESCRIPTION="Nintendo DS emulator"
HOMEPAGE="http://desmume.org/"
SRC_URI="mirror://sourceforge/desmume/${P}.tar.gz"
@@ -12,17 +14,18 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=x11-libs/gtk+-2.8.0:2
- gnome-base/libglade
- x11-libs/gtkglext
- virtual/opengl
- sys-libs/zlib
+RDEPEND="
dev-libs/zziplib
+ gnome-base/libglade
media-libs/libsdl[joystick,opengl,video]
- x11-libs/agg"
+ sys-libs/zlib
+ virtual/opengl
+ x11-libs/agg
+ >=x11-libs/gtk+-2.8.0:2
+ x11-libs/gtkglext"
DEPEND="${RDEPEND}
- virtual/pkgconfig
- dev-util/intltool"
+ dev-util/intltool
+ virtual/pkgconfig"
DOCS=( AUTHORS ChangeLog README README.LIN )
@@ -31,4 +34,5 @@ DOCS=( AUTHORS ChangeLog README README.LIN )
PATCHES=(
"${FILESDIR}/${P}-fix-pointer-conversion-warning.diff"
"${FILESDIR}/${P}-gcc6.patch"
+ "${FILESDIR}/${P}-gcc7.patch"
)