summaryrefslogtreecommitdiff
path: root/games-board/xscrabble
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/xscrabble')
-rw-r--r--games-board/xscrabble/Manifest7
-rw-r--r--games-board/xscrabble/files/xscrabble-2.10-build.patch13
-rw-r--r--games-board/xscrabble/files/xscrabble-2.10-path-fixes.patch35
-rw-r--r--games-board/xscrabble/metadata.xml11
-rw-r--r--games-board/xscrabble/xscrabble-2.10-r2.ebuild56
5 files changed, 122 insertions, 0 deletions
diff --git a/games-board/xscrabble/Manifest b/games-board/xscrabble/Manifest
new file mode 100644
index 000000000000..7600f8356bde
--- /dev/null
+++ b/games-board/xscrabble/Manifest
@@ -0,0 +1,7 @@
+AUX xscrabble-2.10-build.patch 305 BLAKE2B a1663515d317f57f534ed94eaea2059b80583826e9b1d831972d8d7eef635cc9c0182f81f70e42d7df6f521ece481d10d7f20b158257f0efee4c08870cb38019 SHA512 f62fba061b464ae9ff4f4e5c15196ac921760e7f6bfe7432a33c157e405a4784ebaa45a08e67ee191faf62f0dc447559df8f73b91d819d4f6d4e3470c335c07e
+AUX xscrabble-2.10-path-fixes.patch 1106 BLAKE2B 4730587df34bc407403624659d9f6d43c0fa2c6aa46fe06f615ed390590c468780c9521d14ec312b429f2a41d60e6dbdb712a52f1e5fb27b9c3e9449b1f1d1af SHA512 50be14204d8b8c4f13153bcdab855c0fac27639d7a09844a5aae794bf3dbdaf1da6b8aa15ac065d2d35f47c47dfa0bec89e4c9f6231a4a7f2b9a095710c912d4
+DIST xscrabble-2.10.tgz 83575 BLAKE2B 0a7ac0713e8b48eaf770d11d8ddf5fc383f870437dbc12b6e90df3fb4c28559e28523f46461e306dde59a68cebf58e854959e58ec688201223eec9825e3c5e7a SHA512 38137b3dfd3156c3748719136a30fbc7f04910538bdbdec3e9d50e3efe326ab7119a45171e0fa2cd95cd81f0642070e2e011c165284766eb7a14bd7d2aa660db
+DIST xscrabble_en.tgz 393527 BLAKE2B 3f5b9d8030ba2711e64b2cc015f8662bdcfc2d3155d34b17be243a57e8c7dc3e4ad5fc6414c745654a8ea5771a9914d38bf5ce95b42e9b7daa70907bd9105b06 SHA512 05e4bca6ec2a9b7698f5c266bf5cede574cbef87883d7cac6dc35084fa2976dcd23f3a2215b674b9f36d7c170e6af021c3ec0884f06c9803cd67ec300651ac41
+DIST xscrabble_fr.tgz 810737 BLAKE2B 26f5601f5d09232a5145c66d1d359c7a6b389a83f10c1ebcddc7579160d417e0b0b9e5bccf7322128451f3941cdeb2177b26f4ddf9a8224ffd551d95f4a83d72 SHA512 f5425fa8bffec57e6eff16a3d33ae4569fc00343e0ed5e4f4e1e189ed02a5be7416c1549b1978042e030efbfb3a484abcac9479e7fe43de929b11d8ccf8ea3e1
+EBUILD xscrabble-2.10-r2.ebuild 1421 BLAKE2B 2e5785de0a18a84a4c1a5bae22df2c71a2c257b5f3b263c6fa6cdfe13a886417989bc57b8a3181366495ff350851b91bc4d1fae285379c1698e51169d654e2d8 SHA512 5aaa92eb29a78257e9c1f1908b2ef22798896ac2902169e5eb05eb50b881c7daa1187c316285e9b2e7b40f7944667784ce124b3bc2b8adf576a78540f963317e
+MISC metadata.xml 330 BLAKE2B 12712dc48fa06f3a64f7e994b853cc26c78eec98d147e1eba89bfd0ae58a134090376b18738090e3d929835cd596afc6fb9efe13dfe631cd8e8444b890470fdf SHA512 eb06666ebcaeac24c97b66c25652551043abae3bcd2764cd95f1d94ab8422a178fb5358d2aa655b75d254462120d36a87e64a2decb0c8a7ac255015ec1ee057e
diff --git a/games-board/xscrabble/files/xscrabble-2.10-build.patch b/games-board/xscrabble/files/xscrabble-2.10-build.patch
new file mode 100644
index 000000000000..7d5214c7db34
--- /dev/null
+++ b/games-board/xscrabble/files/xscrabble-2.10-build.patch
@@ -0,0 +1,13 @@
+respect compiler, ldflags and cflags
+
+--- build
++++ build
+@@ -36,7 +36,7 @@
+ #define RULES_FILE \"$LIBDIR/en/scrabble_rules\"
+ " > src/config.h
+ xmkmf -a
+- make
++ make CC="${CC}" CCOPTIONS="${CFLAGS}" LOCAL_LDFLAGS="${LDFLAGS}"
+ echo "
+ Now, type './build install' to install programs in $BINDIR
+ "
diff --git a/games-board/xscrabble/files/xscrabble-2.10-path-fixes.patch b/games-board/xscrabble/files/xscrabble-2.10-path-fixes.patch
new file mode 100644
index 000000000000..27a18689b1ed
--- /dev/null
+++ b/games-board/xscrabble/files/xscrabble-2.10-path-fixes.patch
@@ -0,0 +1,35 @@
+--- build
++++ build
+@@ -1,9 +1,10 @@
+ #!/bin/sh
+
+ # Install defaults
+-APPDEFAULTS=/usr/lib/X11/app-defaults
+-BINDIR=/usr/games/bin
+-LIBDIR=/usr/games/lib/scrabble
++APPDEFAULTS=$DESTDIR/usr/$LIBDIR/X11/app-defaults
++REAL_APPDEFAULTS=/usr/$LIBDIR/X11/app-defaults
++BINDIR=$DESTDIR/usr/games/bin
++LIBDIR=$DESTDIR/usr/share/games/xscrabble
+
+ # Version (don't modify without knowing!!)
+ MAJOR=2
+@@ -53,6 +54,7 @@
+
+ if test "$1" = "install" ; then
+ mkdirhier $BINDIR
++ mkdir -p $APPDEFAULTS
+ echo "mkdirhier $BINDIR"
+ install -c -s src/xscrab $BINDIR
+ echo "install -c -s src/xscrab $BINDIR"
+@@ -90,8 +92,8 @@
+ echo "mv -f xscrabble_$2/app-defaults/XScrabble_$2 $APPDEFAULTS"
+ rm -f $APPDEFAULTS/XScrabble
+ echo "rm -f $APPDEFAULTS/XScrabble"
+- ln -fs $APPDEFAULTS/XScrabble_$2 $APPDEFAULTS/XScrabble
+- echo "ln -fs $APPDEFAULTS/XScrabble_$2 $APPDEFAULTS/XScrabble"
++ ln -fs $REAL_APPDEFAULTS/XScrabble_$2 $APPDEFAULTS/XScrabble
++ echo "ln -fs $REAL_APPDEFAULTS/XScrabble_$2 $APPDEFAULTS/XScrabble"
+ chmod a+rwx $LIBDIR/$2
+ chmod a+rw $LIBDIR/$2/scrabble_scores
+ rm -rf xscrabble_$2
diff --git a/games-board/xscrabble/metadata.xml b/games-board/xscrabble/metadata.xml
new file mode 100644
index 000000000000..a36c86cbd53d
--- /dev/null
+++ b/games-board/xscrabble/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="freshmeat">xscrabble</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-board/xscrabble/xscrabble-2.10-r2.ebuild b/games-board/xscrabble/xscrabble-2.10-r2.ebuild
new file mode 100644
index 000000000000..2ea0730cfc70
--- /dev/null
+++ b/games-board/xscrabble/xscrabble-2.10-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils multilib games
+
+DESCRIPTION="An X11 clone of the well-known Scrabble"
+HOMEPAGE="http://freshmeat.net/projects/xscrabble/?topic_id=80"
+SRC_URI="ftp://ftp.ac-grenoble.fr/ge/educational_games/${P}.tgz
+ l10n_fr? ( ftp://ftp.ac-grenoble.fr/ge/educational_games/xscrabble_fr.tgz )
+ ftp://ftp.ac-grenoble.fr/ge/educational_games/xscrabble_en.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="l10n_fr"
+
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}
+ x11-misc/gccmakedep
+ x11-misc/imake"
+
+src_unpack() {
+ unpack ${P}.tgz
+ cp "${DISTDIR}"/xscrabble_en.tgz .
+ use l10n_fr && cp "${DISTDIR}"/xscrabble_fr.tgz .
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-path-fixes.patch \
+ "${FILESDIR}"/${P}-build.patch
+ sed -i '/install/s/-s //' build || die "sed failed"
+}
+
+src_compile() {
+ ./build bin || die "build failed"
+}
+
+src_install() {
+ local f
+ export DESTDIR="${D}" LIBDIR="$(get_libdir)"
+ ./build install || die "install failed"
+ if use l10n_fr ; then
+ ./build lang fr || die "fr failed"
+ fi
+ ./build lang en || die "en failed"
+ for f in "${D}"/usr/"${LIBDIR}"/X11/app-defaults/* ; do
+ [[ -L ${f} ]] && continue
+ sed -i \
+ -e "s:/usr/games/lib/scrabble/:${GAMES_DATADIR}/${PN}/:" \
+ -e "s:fr/eng:fr/en:" \
+ ${f} || die "sed ${f} failed"
+ done
+ dodoc CHANGES README
+ prepgamesdirs
+}