summaryrefslogtreecommitdiff
path: root/games-board/xmille/xmille-2.0-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/xmille/xmille-2.0-r4.ebuild')
-rw-r--r--games-board/xmille/xmille-2.0-r4.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/games-board/xmille/xmille-2.0-r4.ebuild b/games-board/xmille/xmille-2.0-r4.ebuild
index 4ca1f38b7603..966fec4aec02 100644
--- a/games-board/xmille/xmille-2.0-r4.ebuild
+++ b/games-board/xmille/xmille-2.0-r4.ebuild
@@ -18,7 +18,7 @@ KEYWORDS="~amd64 ~x86"
BDEPEND="
app-text/rman
- x11-misc/imake
+ >=x11-misc/imake-1.0.8-r1
"
RDEPEND="x11-libs/libXext"
DEPEND="${RDEPEND}"
@@ -29,12 +29,13 @@ src_prepare() {
}
src_configure() {
- xmkmf || die
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
}
src_compile() {
emake -j1 \
- AR="$(tc-getAR) clq" \
+ AR="$(tc-getAR) cq" \
RANLIB="$(tc-getRANLIB)" \
CC="$(tc-getCC)" \
CDEBUGFLAGS="${CFLAGS}" \