summaryrefslogtreecommitdiff
path: root/games-board/xmahjongg/xmahjongg-3.7-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/xmahjongg/xmahjongg-3.7-r1.ebuild')
-rw-r--r--games-board/xmahjongg/xmahjongg-3.7-r1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/games-board/xmahjongg/xmahjongg-3.7-r1.ebuild b/games-board/xmahjongg/xmahjongg-3.7-r1.ebuild
index e05ea7454d84..15198d767d8a 100644
--- a/games-board/xmahjongg/xmahjongg-3.7-r1.ebuild
+++ b/games-board/xmahjongg/xmahjongg-3.7-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils
+EAPI=7
+
+inherit autotools desktop
DESCRIPTION="friendly GUI version of xmahjongg"
HOMEPAGE="http://www.lcdf.org/xmahjongg/"
@@ -11,21 +12,22 @@ SRC_URI="http://www.lcdf.org/xmahjongg/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~mips ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
RDEPEND="x11-libs/libX11"
DEPEND="${RDEPEND}
x11-libs/libXt"
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+
src_prepare() {
default
- sed -i \
- -e '/X_PRE_LIBS/s:-lSM -lICE::' \
- configure || die
+ mv configure.{in,ac} || die
+ eautoreconf
}
src_install() {
default
+
newicon share/tiles/small.gif ${PN}.gif
make_desktop_entry xmahjongg "Xmahjongg" /usr/share/pixmaps/${PN}.gif
}