summaryrefslogtreecommitdiff
path: root/games-board/xfreecell/xfreecell-1.0.5b-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/xfreecell/xfreecell-1.0.5b-r1.ebuild')
-rw-r--r--games-board/xfreecell/xfreecell-1.0.5b-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-board/xfreecell/xfreecell-1.0.5b-r1.ebuild b/games-board/xfreecell/xfreecell-1.0.5b-r1.ebuild
new file mode 100644
index 000000000000..b5e38916ce0a
--- /dev/null
+++ b/games-board/xfreecell/xfreecell-1.0.5b-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A freecell game for X"
+HOMEPAGE="http://www2.giganet.net/~nakayama/"
+SRC_URI="http://www2.giganet.net/~nakayama/${P}.tgz
+ http://www2.giganet.net/~nakayama/MSNumbers.gz
+ https://dev.gentoo.org/~dilfridge/distfiles/${P}-gcc6.patch.xz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="media-fonts/font-misc-misc
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${WORKDIR}"/${P}-gcc6.patch
+)
+
+src_install() {
+ dobin xfreecell
+ insinto /usr/share/${PN}
+ doins "${WORKDIR}"/MSNumbers
+ dodoc CHANGES README mshuffle.txt
+ doman xfreecell.6
+ make_desktop_entry xfreecell XFreecell
+}
+
+pkg_postinst() {
+ einfo "Remember to restart X if this is the first time you've installed media-fonts/font-misc-misc"
+}