summaryrefslogtreecommitdiff
path: root/games-board/pokerth
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/pokerth')
-rw-r--r--games-board/pokerth/Manifest5
-rw-r--r--games-board/pokerth/files/pokerth-1.1.1-boost-1.65-ambiguous-advance.patch14
-rw-r--r--games-board/pokerth/files/pokerth-1.1.2-protobuf.patch23
-rw-r--r--games-board/pokerth/metadata.xml11
-rw-r--r--games-board/pokerth/pokerth-1.1.2.ebuild71
5 files changed, 124 insertions, 0 deletions
diff --git a/games-board/pokerth/Manifest b/games-board/pokerth/Manifest
new file mode 100644
index 000000000000..eddeea2f217d
--- /dev/null
+++ b/games-board/pokerth/Manifest
@@ -0,0 +1,5 @@
+AUX pokerth-1.1.1-boost-1.65-ambiguous-advance.patch 465 BLAKE2B 4b7cb201233754ce5bc57338e7bcc8c03baebf3c021a34f01cfe221fba9062b6d2a51a5ee4c5644f0535de7a7bdccb27b6ae488a94fbcbcc2863b763a3b5103a SHA512 af91b98c04f844504c46b01c76a360d00bfe3993d6acdbc9800f2466833da42ad5e76a0ca3e197cb63aca10e4cb1eae73996b67691587eae2f2ee3975a33410e
+AUX pokerth-1.1.2-protobuf.patch 603 BLAKE2B 258ab192bf8c27266bc96103adfd52c0da9d719f07da674d31411f3248106fe919be741ab2829a250dba34e6eeaf023f9fbd6517581418c7f77b080ad47e34ab SHA512 ddb0ec7f60a0e494822e9c7abe9c9658c5df3b27e6be99624c5c959f0cc8db58ad13fb00ea947cfd3e81e48278ff27af8d09fec5e5c3acf31fe78ce70db89e1b
+DIST pokerth-1.1.2.tar.gz 21354306 BLAKE2B d8e1ecc46e61d9c16ae3949099f6e72271a5ab2def9799652b0c612980e0c5e96cb2ccf4d659c1a90b9ac6433af95587fa5d44af80c16fb6a34a272751c9fc4a SHA512 d54c84f199636eb5a53580213e5e4ccc828cf565bf4b055797daa82e2ad54d8c52c7a16a781b82c8cc89d184a2b3c4105922394d08c7d2e06383b96963c36b5a
+EBUILD pokerth-1.1.2.ebuild 1526 BLAKE2B 04e9971784afed63ca064c9587f1c83c1c267292d1f415d3e9e69bdc4e2811fd72e2cf0daa6d6f615be3221b92356b99fdd0806ab84e62b41576c44b14d44ac0 SHA512 724b42865bf254bf85591dec6a4c450ee4737c8ba0ffe607eb289a85d5f3a75cabf5949cea980a05163d4954df51ea68370af86bf5e57b4a28922dd68214e74a
+MISC metadata.xml 340 BLAKE2B e271d172e85302ebcaf0ad3f355035e16056764ae73b01faf494659f0b82c9b0060448e518732e56b13c25ad676156124b11b28ebfdff4697eddc4524ddaf278 SHA512 640db7890ea68059399c50c0ab24c337e0a4cd1c977c2b87198ee9af25e39547fadd3fd83f081da6afa62ae9a9ae2fa450b45a83519d66b036e357ecc3e9b705
diff --git a/games-board/pokerth/files/pokerth-1.1.1-boost-1.65-ambiguous-advance.patch b/games-board/pokerth/files/pokerth-1.1.1-boost-1.65-ambiguous-advance.patch
new file mode 100644
index 000000000000..2e8c9c50c5eb
--- /dev/null
+++ b/games-board/pokerth/files/pokerth-1.1.1-boost-1.65-ambiguous-advance.patch
@@ -0,0 +1,14 @@
+Boost 1.65 made 'advance()' ambiguous.
+Bug: https://bugs.gentoo.org/show_bug.cgi?id=629966
+
+--- a/src/gui/qt/gametable/gametableimpl.cpp
++++ b/src/gui/qt/gametable/gametableimpl.cpp
+@@ -3859,7 +3859,7 @@
+ int playerCount = static_cast<int>(seatList->size());
+ if (id < playerCount) {
+ PlayerListIterator pos = seatList->begin();
+- advance(pos, id);
++ std::advance(pos, id);
+ myStartWindow->getSession()->startVoteKickPlayer((*pos)->getMyUniqueID());
+ }
+ }
diff --git a/games-board/pokerth/files/pokerth-1.1.2-protobuf.patch b/games-board/pokerth/files/pokerth-1.1.2-protobuf.patch
new file mode 100644
index 000000000000..0ac2ab0b1531
--- /dev/null
+++ b/games-board/pokerth/files/pokerth-1.1.2-protobuf.patch
@@ -0,0 +1,23 @@
+https://github.com/pokerth/pokerth/issues/339
+--- PokerTH-1.1.1-src/pokerth.proto
++++ PokerTH-1.1.1-src.new/pokerth.proto
+@@ -701,7 +701,7 @@
+
+ message ErrorMessage {
+ enum ErrorReason {
+- reserved = 0;
++ custReserved = 0;
+ initVersionNotSupported = 1;
+ initServerFull = 2;
+ initAuthFailure = 3;
+--- PokerTH-1.1.1-src/src/net/common/netpacket.cpp
++++ PokerTH-1.1.1-src.new/src/net/common/netpacket.cpp
+@@ -249,7 +249,7 @@
+ retVal = ErrorMessage::sessionTimeout;
+ break;
+ default :
+- retVal = ErrorMessage::reserved;
++ retVal = ErrorMessage::custReserved;
+ break;
+ }
+ return retVal;
diff --git a/games-board/pokerth/metadata.xml b/games-board/pokerth/metadata.xml
new file mode 100644
index 000000000000..add52ba75f21
--- /dev/null
+++ b/games-board/pokerth/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">pokerth</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-board/pokerth/pokerth-1.1.2.ebuild b/games-board/pokerth/pokerth-1.1.2.ebuild
new file mode 100644
index 000000000000..3a84288bbc76
--- /dev/null
+++ b/games-board/pokerth/pokerth-1.1.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop gnome2-utils qmake-utils
+
+DESCRIPTION="Texas Hold'em poker game"
+HOMEPAGE="https://www.pokerth.net/"
+SRC_URI="mirror://sourceforge/pokerth/${P}.tar.gz"
+
+LICENSE="AGPL-3 GPL-1 GPL-2 GPL-3 BitstreamVera public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/boost:0=[threads(+)]
+ dev-libs/libgcrypt:0
+ dev-libs/protobuf:0=
+ dev-libs/tinyxml[stl]
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ >=net-libs/libircclient-1.6-r2
+ >=net-misc/curl-7.16
+ virtual/gsasl
+ !dedicated? (
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/libsdl:0
+ media-libs/sdl-mixer[mod,vorbis]
+ )"
+DEPEND="${RDEPEND}
+ !dedicated? ( dev-qt/qtsql:5 )
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${P}-rc"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.1-boost-1.65-ambiguous-advance.patch
+ "${FILESDIR}"/${PN}-1.1.2-protobuf.patch
+)
+
+src_prepare() {
+ default
+ sed -i 's/!client//' *.pro || die
+}
+
+src_configure() {
+ eqmake5 pokerth.pro \
+ QMAKE_CFLAGS_ISYSTEM= \
+ CONFIG+="$(use dedicated || echo client)"
+}
+
+src_install() {
+ dobin bin/pokerth_server chatcleaner
+ dodoc docs/{gui_styling,server_setup}_howto.txt
+ doman docs/pokerth.1
+
+ if ! use dedicated; then
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r data
+ domenu ${PN}.desktop
+ doicon -s 128 ${PN}.png
+ fi
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }