summaryrefslogtreecommitdiff
path: root/games-board/openyahtzee/openyahtzee-1.9.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/openyahtzee/openyahtzee-1.9.3-r2.ebuild')
-rw-r--r--games-board/openyahtzee/openyahtzee-1.9.3-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-board/openyahtzee/openyahtzee-1.9.3-r2.ebuild b/games-board/openyahtzee/openyahtzee-1.9.3-r2.ebuild
new file mode 100644
index 000000000000..9ded508d8921
--- /dev/null
+++ b/games-board/openyahtzee/openyahtzee-1.9.3-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit flag-o-matic wxwidgets
+
+DESCRIPTION="Full-featured wxWidgets version of the classic dice game Yahtzee"
+HOMEPAGE="https://openyahtzee.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openyahtzee/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+"
+
+PATCHES=( "${FILESDIR}"/${P}-wx32.patch )
+
+src_configure() {
+ append-cxxflags -std=c++11
+ setup-wxwidgets
+ econf --datadir=/usr/share
+}