summaryrefslogtreecommitdiff
path: root/games-board/openyahtzee/openyahtzee-1.9.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/openyahtzee/openyahtzee-1.9.3-r1.ebuild')
-rw-r--r--games-board/openyahtzee/openyahtzee-1.9.3-r1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/games-board/openyahtzee/openyahtzee-1.9.3-r1.ebuild b/games-board/openyahtzee/openyahtzee-1.9.3-r1.ebuild
deleted file mode 100644
index d6c0225fb583..000000000000
--- a/games-board/openyahtzee/openyahtzee-1.9.3-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-WX_GTK_VER="3.0"
-inherit flag-o-matic toolchain-funcs wxwidgets
-
-DESCRIPTION="Full-featured wxWidgets version of the classic dice game Yahtzee"
-HOMEPAGE="https://openyahtzee.sourceforge.net/"
-SRC_URI="https://downloads.sourceforge.net/openyahtzee/${P}.tar.xz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
-DEPEND="
- ${RDEPEND}
- dev-libs/boost
-"
-
-pkg_pretend() {
- local ver=4.6
- local msg="You need at least GCC ${ver}.x for C++11 range-based 'for' and nullptr support."
-
- if tc-is-gcc ; then
- if ver_test ${ver} -gt $(gcc-version); then
- die ${msg}
- fi
- else
- ewarn "Ensure your compiler has C++11 support, otherwise build will fail."
- fi
-}
-
-src_configure() {
- append-cxxflags -std=c++11
- setup-wxwidgets
- econf --datadir=/usr/share
-}