summaryrefslogtreecommitdiff
path: root/games-board/maitretarot/maitretarot-0.1.98.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/maitretarot/maitretarot-0.1.98.ebuild')
-rw-r--r--games-board/maitretarot/maitretarot-0.1.98.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-board/maitretarot/maitretarot-0.1.98.ebuild b/games-board/maitretarot/maitretarot-0.1.98.ebuild
new file mode 100644
index 000000000000..b7a22eea2e23
--- /dev/null
+++ b/games-board/maitretarot/maitretarot-0.1.98.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit games eutils
+
+DESCRIPTION="server for the french tarot game maitretarot"
+HOMEPAGE="http://www.nongnu.org/maitretarot/"
+SRC_URI="https://savannah.nongnu.org/download/maitretarot/${PN}.pkg/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/glib:2
+ dev-libs/libxml2
+ dev-games/libmaitretarot"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format.patch
+}
+
+src_configure() {
+ egamesconf \
+ --with-default-config-file="${GAMES_SYSCONFDIR}/maitretarotrc.xml"
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}