summaryrefslogtreecommitdiff
path: root/games-board/gtkatlantic/gtkatlantic-0.6.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/gtkatlantic/gtkatlantic-0.6.1-r1.ebuild')
-rw-r--r--games-board/gtkatlantic/gtkatlantic-0.6.1-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-board/gtkatlantic/gtkatlantic-0.6.1-r1.ebuild b/games-board/gtkatlantic/gtkatlantic-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..a4f03258084b
--- /dev/null
+++ b/games-board/gtkatlantic/gtkatlantic-0.6.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="Monopoly-like game that works with the monopd server"
+HOMEPAGE="http://gtkatlantic.gradator.net/"
+SRC_URI="http://download.tuxfamily.org/gtkatlantic/downloads/v0.6/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libxml2
+ media-libs/libpng:0
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-warnings.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's:$(datadir):/usr/share:' {,data/}Makefile.am || die
+ sed -i -e 's/configure.in/configure.ac/' configure.in || die
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-icons-path=/usr/share/icons/hicolor
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}