summaryrefslogtreecommitdiff
path: root/games-board/gnono/gnono-1.9.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/gnono/gnono-1.9.1-r1.ebuild')
-rw-r--r--games-board/gnono/gnono-1.9.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-board/gnono/gnono-1.9.1-r1.ebuild b/games-board/gnono/gnono-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..9d5ede968dd4
--- /dev/null
+++ b/games-board/gnono/gnono-1.9.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="A rewrite for GNOME of the Windows card game WUNO"
+HOMEPAGE="https://sourceforge.net/projects/gnono/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="gnome-base/libgnomeui
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-glib-single-include.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}