summaryrefslogtreecommitdiff
path: root/games-board/gnome-mines/gnome-mines-3.24.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/gnome-mines/gnome-mines-3.24.0.ebuild')
-rw-r--r--games-board/gnome-mines/gnome-mines-3.24.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-board/gnome-mines/gnome-mines-3.24.0.ebuild b/games-board/gnome-mines/gnome-mines-3.24.0.ebuild
new file mode 100644
index 000000000000..8dd488ac7daf
--- /dev/null
+++ b/games-board/gnome-mines/gnome-mines-3.24.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 vala
+
+DESCRIPTION="Clear hidden mines from a minefield"
+HOMEPAGE="https://wiki.gnome.org/Apps/Mines"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2
+ dev-libs/libgnome-games-support:1
+ >=gnome-base/librsvg-2.32.0:2
+ >=x11-libs/gtk+-3.12:3
+"
+RDEPEND="${COMMON_DEPEND}
+ !<x11-themes/gnome-themes-standard-3.14
+"
+DEPEND="${COMMON_DEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ vala_src_prepare
+}