summaryrefslogtreecommitdiff
path: root/games-board/gmchess/gmchess-0.29.6-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/gmchess/gmchess-0.29.6-r3.ebuild')
-rw-r--r--games-board/gmchess/gmchess-0.29.6-r3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-board/gmchess/gmchess-0.29.6-r3.ebuild b/games-board/gmchess/gmchess-0.29.6-r3.ebuild
new file mode 100644
index 000000000000..fbd0e59250a6
--- /dev/null
+++ b/games-board/gmchess/gmchess-0.29.6-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic xdg
+
+DESCRIPTION="Chinese chess with gtkmm and c++"
+HOMEPAGE="https://github.com/lerosua/gmchess"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.bz2"
+RESTRICT="test"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-cpp/gtkmm:2.4"
+RDEPEND=${DEPEND}
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo-r1.patch
+ "${FILESDIR}"/${P}_fix_build_segfault.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac}
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf \
+ --disable-static \
+ --localedir='/usr/share/locale'
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ localedir="${EPREFIX}"/usr/share/locale \
+ pixmapsdir="${EPREFIX}"/usr/share/pixmaps \
+ desktopdir="${EPREFIX}"/usr/share/applications \
+ install
+ dodoc AUTHORS NEWS README
+ find "${ED}" -name "*.la" -delete || die
+}