summaryrefslogtreecommitdiff
path: root/games-board/domination
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/domination')
-rw-r--r--games-board/domination/Manifest3
-rw-r--r--games-board/domination/domination-1.1.1.6-r1.ebuild47
-rw-r--r--games-board/domination/metadata.xml11
3 files changed, 61 insertions, 0 deletions
diff --git a/games-board/domination/Manifest b/games-board/domination/Manifest
new file mode 100644
index 000000000000..3cff1209ba7c
--- /dev/null
+++ b/games-board/domination/Manifest
@@ -0,0 +1,3 @@
+DIST Domination_1.1.1.6.zip 6567410 BLAKE2B 5868011017c9aae937d3d21c8568a541a5170a716c6762e2802e5fdb34a31dd7c4c61a0670278b211e6227f42bc996a81547b04d71533c83dfb2f6045dd190cb SHA512 46f4499f285f86cf94914ef62b25a52aa3b9848721c24900ec172f9b41d846dab07e288c564321486d451caee6049b4f4cb0ab475e378aa6df670e656b5b1fe6
+EBUILD domination-1.1.1.6-r1.ebuild 981 BLAKE2B 024a7349183b49b8c16ea63b0103556da37eaa9dd7573b7ddb045ff2ccb1c17fbead0528c906243f001598ce4a30312537e09cb9a2c9687bedf7f4adf7baea0c SHA512 76eecb9f95131f351ef5440d5c942c49c9c58f32fc21a99f842a66f00799b51bfd41ebfee0fb7bd217db0f31a2c8cdcec4fd60d082110a45b16a920a01503720
+MISC metadata.xml 333 BLAKE2B 2064b61753a5170ad5958694ca7f3e23c53df711aa092e21f920834390a95691b1363a7fe6dade20f9724fe3e6a0968ca9ef30364993ce56731f1bb22750faa8 SHA512 1ced4b2460bea74b56f982156c0088c43f26ae33459771ceb6cf904e8957a4c3bb46c16dbd3de20d9aa9b3b816aeb3e1a741b74a1f246e823d17ae78cb6cca24
diff --git a/games-board/domination/domination-1.1.1.6-r1.ebuild b/games-board/domination/domination-1.1.1.6-r1.ebuild
new file mode 100644
index 000000000000..75932d0ed60d
--- /dev/null
+++ b/games-board/domination/domination-1.1.1.6-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="The well-known board game, written in java"
+HOMEPAGE="http://domination.sourceforge.net"
+SRC_URI="mirror://sourceforge/domination/Domination_${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+
+S=${WORKDIR}/Domination
+
+EANT_BUILD_TARGET="game"
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+}
+
+src_compile() {
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ newbin "${S}"/FlashGUI.sh ${PN}
+ sed -i \
+ -e "s|cd.*|cd \"/usr/share\"/${PN}|" \
+ "${D}/usr/bin"/${PN} \
+ || die
+ chmod +x "${D}/usr/bin"/${PN} || die
+
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ rm -f "${D}/usr/share"/${PN}/*.cmd || die
+ java-pkg_regjar "${D}//usr/share/${PN}"/*.jar
+
+ newicon resources/icon.png ${PN}.png
+ make_desktop_entry ${PN} "Domination"
+}
diff --git a/games-board/domination/metadata.xml b/games-board/domination/metadata.xml
new file mode 100644
index 000000000000..a3bf00dd794f
--- /dev/null
+++ b/games-board/domination/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">domination</remote-id>
+ </upstream>
+</pkgmetadata>