summaryrefslogtreecommitdiff
path: root/games-board/ccgo
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/ccgo')
-rw-r--r--games-board/ccgo/Manifest4
-rw-r--r--games-board/ccgo/ccgo-0.3.6.5-r1.ebuild60
-rw-r--r--games-board/ccgo/files/ccgo-0.3.6.5-gcc4.patch12
-rw-r--r--games-board/ccgo/metadata.xml8
4 files changed, 84 insertions, 0 deletions
diff --git a/games-board/ccgo/Manifest b/games-board/ccgo/Manifest
new file mode 100644
index 000000000000..ed329679fd7f
--- /dev/null
+++ b/games-board/ccgo/Manifest
@@ -0,0 +1,4 @@
+AUX ccgo-0.3.6.5-gcc4.patch 204 BLAKE2B 7cf7b69699dacb14b03308d5959016eda17ed92cf4da86239e3e37a680c5f2efc3f0417ecc01743c53ec229ca2c808eb7aa417718d60f1961c8ff99667c0d4d8 SHA512 86d8f663e3058076f63526217a15f4c8bdc70dc178d48b26a032c38b1bfe02cad4ce28de08889312cd769e39d927e427b14bbbf2631e3455a7e219fbf49ed95d
+DIST ccgo-0.3.6.5.tar.gz 639238 BLAKE2B a0e67cbfe270c7dd4906e01545310e3a93fcf5ff843c987917df36209846fbae4297e3a6f61b5c321a12ce157bcfb516da0ca28a700ca869944127ac05b1eb68 SHA512 268c228eee9c42e49df333bfa0707e7b72c39731ccd64239e3c426958f6c17b65658db91bc7ab89548c4cc647ade791a7c67c30c410a5b3935c8fd3f326bf36b
+EBUILD ccgo-0.3.6.5-r1.ebuild 1251 BLAKE2B cf3613a2c4cccf481ce2c6678496324b9e6614733440945f21cae6ee8304c689fb9d3452f0bfad4da5c6c8592fa8f05e0d5982eccb8b8013c80425b2eb07ad96 SHA512 5cc52c875a524b59f1f2aa84a6b459e7a70ffe4e0b6a6005753716a36b1bb71b9691554fb7866d9dcae0e908b04c7464b2ed22411f374d0a3c35ffbc89ebcbb1
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-board/ccgo/ccgo-0.3.6.5-r1.ebuild b/games-board/ccgo/ccgo-0.3.6.5-r1.ebuild
new file mode 100644
index 000000000000..9f19d9aa9e48
--- /dev/null
+++ b/games-board/ccgo/ccgo-0.3.6.5-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="An IGS client written in C++"
+HOMEPAGE="https://ccdw.org/~cjj/prog/ccgo/"
+SRC_URI="https://ccdw.org/~cjj/prog/ccgo/src/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ >=dev-cpp/gconfmm-2.6
+ >=dev-cpp/gtkmm-2.4:2.4
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc4.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^Encoding/d' \
+ -e '/^Categories/ { s/Application;//; s/$/GTK;/ }' \
+ ccgo.desktop.in || die
+
+ sed -i \
+ -e '/^localedir/s/=.*/=@localedir@/' \
+ -e '/^appicondir/s:=.*:=/usr/share/pixmaps:' \
+ -e '/^desktopdir/s:=.*:=/usr/share/applications:' \
+ Makefile.am || die
+
+ # cargo cult from bug #569528
+ append-cxxflags -std=c++11 -fpermissive
+
+ find . -name '*.hh' -exec sed -i -e '/sigc++\/object.h/d' {} + || die
+ find . -name '*.cc' -exec sed -i -e 's/(bind(/(sigc::bind(/' {} + || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localedir=/usr/share/locale \
+ $(use_enable nls)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
diff --git a/games-board/ccgo/files/ccgo-0.3.6.5-gcc4.patch b/games-board/ccgo/files/ccgo-0.3.6.5-gcc4.patch
new file mode 100644
index 000000000000..79f73863670a
--- /dev/null
+++ b/games-board/ccgo/files/ccgo-0.3.6.5-gcc4.patch
@@ -0,0 +1,12 @@
+--- a/gtk/board.cc
++++ b/gtk/board.cc
+@@ -20,9 +20,7 @@
+ */
+
+ #include <config.hh>
+-extern "C" {
+ #include <gettext.h>
+-}
+ #define _(String) Glib::locale_to_utf8(gettext(String))
+
+ #include <board.hh>
diff --git a/games-board/ccgo/metadata.xml b/games-board/ccgo/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-board/ccgo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>