summaryrefslogtreecommitdiff
path: root/games-board/blokish/blokish-0.9.4-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/blokish/blokish-0.9.4-r3.ebuild')
-rw-r--r--games-board/blokish/blokish-0.9.4-r3.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/games-board/blokish/blokish-0.9.4-r3.ebuild b/games-board/blokish/blokish-0.9.4-r3.ebuild
index e45372c8a487..7316facb2a61 100644
--- a/games-board/blokish/blokish-0.9.4-r3.ebuild
+++ b/games-board/blokish/blokish-0.9.4-r3.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
WX_GTK_VER="3.0"
-inherit eutils autotools wxwidgets
+inherit autotools desktop wxwidgets
MY_P="${PN}_v${PV}"
+
DESCRIPTION="Open source clone of the four-player board game Blokus"
HOMEPAGE="https://sourceforge.net/projects/blokish/"
SRC_URI="mirror://sourceforge/blokish/${MY_P}.tgz"
+S="${WORKDIR}"/${PN}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
virtual/glu
virtual/opengl"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/${PN}
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-gcc43.patch
@@ -45,9 +45,8 @@ src_prepare() {
src_install() {
default
+ dodoc -r docs/.
doicon src/${PN}.xpm
make_desktop_entry ${PN} Blokish ${PN}
-
- dodoc docs/*
}