summaryrefslogtreecommitdiff
path: root/games-board/atakks
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/atakks')
-rw-r--r--games-board/atakks/Manifest5
-rw-r--r--games-board/atakks/atakks-1.0-r1.ebuild48
-rw-r--r--games-board/atakks/files/1.0-warnings.patch28
-rw-r--r--games-board/atakks/files/atakks-1.0-as-needed.patch16
-rw-r--r--games-board/atakks/metadata.xml8
5 files changed, 105 insertions, 0 deletions
diff --git a/games-board/atakks/Manifest b/games-board/atakks/Manifest
new file mode 100644
index 000000000000..1a11868cc1cc
--- /dev/null
+++ b/games-board/atakks/Manifest
@@ -0,0 +1,5 @@
+AUX 1.0-warnings.patch 974 BLAKE2B 54ead5cdd8b43c812f11685f053b9a8fa8eaa5aa8da2d4a585bf4b8c90180a7d53036ec6ec230f47ea2beeb0361579d6dc732c435fd1763a8f83af466d9ab3dc SHA512 36911a16c5a9ea3db5a13fb9cb38e6481465016d1d58d1d255730ee35aad44e9356a1493ce93a010d5544b28d8e3ea35d40087e95dc86e577904eb033025b411
+AUX atakks-1.0-as-needed.patch 443 BLAKE2B 8d9ea8a04f2ca9cfc592427bd22223ba77c25796c2c3b6d4a5cf4ffd129e279da4b50d5c2377e0313acda12807ced7b30557fc705d4c272ccdf219338a8ef281 SHA512 6280db8cd198caf320daa85773358f92b0bcf71c243b5ab36ccc989fb7c88fdeab2de8a1dc4ce45c97977b2f5ac026e811db1e1e6b3683759d2e5f639fa2155d
+DIST atakks-1.0.tar.gz 62464 BLAKE2B 1419e4fff60121e0bd793322cd20515335ad82d9b1341ab9ae658aa5e2882af3457440485318b1d872f9f8f483c22b21d8dc55f5d4862694427d08fb52e93e85 SHA512 a4b31635ef74198c86002fc930922266f462926bffa5b1fd7fb8ba1186dbc1efd8ae8c84ac0a429737916d1350b5432967221a67505bfe73d47a6dadd7600e39
+EBUILD atakks-1.0-r1.ebuild 894 BLAKE2B 680740590cd12d1df67781ba1a043539cc345774076c90bf8ea2c6db1ce8b83269447b5ac7cb9ecc71c524edf7a39616d9801ee267c235604b1e7771b2450045 SHA512 6c564d8d03622a883c8e99a86d3753b73be46f8baa360d596245b2c44a6188f39be76a150a8bb1c0ce461a47c81ec77a9a8b4eb2bd92d1f8b4cbdc1595b09359
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-board/atakks/atakks-1.0-r1.ebuild b/games-board/atakks/atakks-1.0-r1.ebuild
new file mode 100644
index 000000000000..052924ba8c88
--- /dev/null
+++ b/games-board/atakks/atakks-1.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+MY_P=${P/-/_}
+DESCRIPTION="A clone of Ataxx"
+HOMEPAGE="http://team.gcu-squad.org/~fab"
+# no version upstream
+#SRC_URI="http://team.gcu-squad.org/~fab/down/${PN}.tgz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl:0"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-warnings.patch
+ "${FILESDIR}"/${P}-as-needed.patch
+)
+
+src_prepare() {
+ default
+
+ # Modify game data paths
+ sed -i \
+ -e "s:SDL_LoadBMP(\":SDL_LoadBMP(\"/usr/share/${PN}/:" \
+ main.c || die
+}
+
+src_compile() {
+ emake E_CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins *bmp
+ newicon icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Atakks /usr/share/pixmaps/${PN}.bmp
+}
diff --git a/games-board/atakks/files/1.0-warnings.patch b/games-board/atakks/files/1.0-warnings.patch
new file mode 100644
index 000000000000..7123bb4f7dd2
--- /dev/null
+++ b/games-board/atakks/files/1.0-warnings.patch
@@ -0,0 +1,28 @@
+--- a/main.c 2004-06-02 01:26:00.000000000 -0700
++++ b/main.c 2004-06-02 01:27:30.000000000 -0700
+@@ -13,6 +13,7 @@
+ #include<SDL/SDL.h>
+ #include<unistd.h>
+ #include<stdlib.h> /* atexit */
++#include<string.h>
+ #include "defs.h"
+ void virus(Uint8 posX, Uint8 posY)
+ {
+@@ -206,7 +207,7 @@
+ int main(int argc, char **argv)
+ {
+ struct move hoho;
+- Uint8 caseX, caseY,selx, sely, checked = 0, canmove = 1;
++ Uint8 caseX, caseY,selx = 0, sely = 0, checked = 0, canmove = 1;
+ SDL_Surface *ico;
+ int pions1=0, pions2=0;
+ if (SDL_Init(SDL_INIT_VIDEO) == -1) {
+@@ -238,7 +239,7 @@
+ argv[0]);
+ #else
+ printf
+- ("\nSyntax: %s OPTIONS\n\n options:\n-h\t\tPrint help\n-t n1 n2\tSet width=n1 and height=n2\n\-ai\t\tActivate 1 player mode, [i] key during game.\n\n",
++ ("\nSyntax: %s OPTIONS\n\n options:\n-h\t\tPrint help\n-t n1 n2\tSet width=n1 and height=n2\n-ai\t\tActivate 1 player mode, [i] key during game.\n\n",
+ argv[0]);
+
+ #endif /* */
diff --git a/games-board/atakks/files/atakks-1.0-as-needed.patch b/games-board/atakks/files/atakks-1.0-as-needed.patch
new file mode 100644
index 000000000000..e496f5ff0d30
--- /dev/null
+++ b/games-board/atakks/files/atakks-1.0-as-needed.patch
@@ -0,0 +1,16 @@
+--- a/Makefile 2009-02-03 10:02:08.000000000 +0100
++++ b/Makefile 2009-02-03 10:04:12.000000000 +0100
+@@ -1,10 +1,10 @@
+-LDFLAGS= -lSDL -lpthread -s
+-CFLAGS= -Wall -ansi # -DDEBUG
++LDLIBS = -lSDL
++CFLAGS= $(E_CFLAGS) -DUS -Wall -ansi # -DDEBUG
+ all: atakks
+ clean:
+ rm atakks *.o
+ atakks: main.o
+- $(CC) $(LDFLAGS) $< -o $@
++ $(CC) $(LDFLAGS) $< -o $@ $(LDLIBS)
+ pkg:
+ mkdir atakks-src
+ cp *.bmp main.c Makefile README atakks-src
diff --git a/games-board/atakks/metadata.xml b/games-board/atakks/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-board/atakks/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>