summaryrefslogtreecommitdiff
path: root/games-board/atakks/files
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/atakks/files')
-rw-r--r--games-board/atakks/files/1.0-warnings.patch28
-rw-r--r--games-board/atakks/files/atakks-1.0-as-needed.patch16
2 files changed, 44 insertions, 0 deletions
diff --git a/games-board/atakks/files/1.0-warnings.patch b/games-board/atakks/files/1.0-warnings.patch
new file mode 100644
index 000000000000..7123bb4f7dd2
--- /dev/null
+++ b/games-board/atakks/files/1.0-warnings.patch
@@ -0,0 +1,28 @@
+--- a/main.c 2004-06-02 01:26:00.000000000 -0700
++++ b/main.c 2004-06-02 01:27:30.000000000 -0700
+@@ -13,6 +13,7 @@
+ #include<SDL/SDL.h>
+ #include<unistd.h>
+ #include<stdlib.h> /* atexit */
++#include<string.h>
+ #include "defs.h"
+ void virus(Uint8 posX, Uint8 posY)
+ {
+@@ -206,7 +207,7 @@
+ int main(int argc, char **argv)
+ {
+ struct move hoho;
+- Uint8 caseX, caseY,selx, sely, checked = 0, canmove = 1;
++ Uint8 caseX, caseY,selx = 0, sely = 0, checked = 0, canmove = 1;
+ SDL_Surface *ico;
+ int pions1=0, pions2=0;
+ if (SDL_Init(SDL_INIT_VIDEO) == -1) {
+@@ -238,7 +239,7 @@
+ argv[0]);
+ #else
+ printf
+- ("\nSyntax: %s OPTIONS\n\n options:\n-h\t\tPrint help\n-t n1 n2\tSet width=n1 and height=n2\n\-ai\t\tActivate 1 player mode, [i] key during game.\n\n",
++ ("\nSyntax: %s OPTIONS\n\n options:\n-h\t\tPrint help\n-t n1 n2\tSet width=n1 and height=n2\n-ai\t\tActivate 1 player mode, [i] key during game.\n\n",
+ argv[0]);
+
+ #endif /* */
diff --git a/games-board/atakks/files/atakks-1.0-as-needed.patch b/games-board/atakks/files/atakks-1.0-as-needed.patch
new file mode 100644
index 000000000000..e496f5ff0d30
--- /dev/null
+++ b/games-board/atakks/files/atakks-1.0-as-needed.patch
@@ -0,0 +1,16 @@
+--- a/Makefile 2009-02-03 10:02:08.000000000 +0100
++++ b/Makefile 2009-02-03 10:04:12.000000000 +0100
+@@ -1,10 +1,10 @@
+-LDFLAGS= -lSDL -lpthread -s
+-CFLAGS= -Wall -ansi # -DDEBUG
++LDLIBS = -lSDL
++CFLAGS= $(E_CFLAGS) -DUS -Wall -ansi # -DDEBUG
+ all: atakks
+ clean:
+ rm atakks *.o
+ atakks: main.o
+- $(CC) $(LDFLAGS) $< -o $@
++ $(CC) $(LDFLAGS) $< -o $@ $(LDLIBS)
+ pkg:
+ mkdir atakks-src
+ cp *.bmp main.c Makefile README atakks-src