summaryrefslogtreecommitdiff
path: root/games-arcade/vor/vor-0.5.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/vor/vor-0.5.7.ebuild')
-rw-r--r--games-arcade/vor/vor-0.5.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-arcade/vor/vor-0.5.7.ebuild b/games-arcade/vor/vor-0.5.7.ebuild
new file mode 100644
index 000000000000..f1bc924bc5d2
--- /dev/null
+++ b/games-arcade/vor/vor-0.5.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Variations on Rockdodger: Dodge the rocks until you die"
+HOMEPAGE="http://jasonwoof.org/vor"
+SRC_URI="https://jasonwoof.com/downloads/vor/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+RDEPEND=${DEPEND}
+
+src_install() {
+ dodir "${GAMES_BINDIR}"
+ DOCS="README* todo" default
+ newicon -s 48 data/icon.png ${PN}.png
+ make_desktop_entry ${PN} VoR
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}