summaryrefslogtreecommitdiff
path: root/games-arcade/trailblazer/files/trailblazer-0.9-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/trailblazer/files/trailblazer-0.9-makefile.patch')
-rw-r--r--games-arcade/trailblazer/files/trailblazer-0.9-makefile.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/games-arcade/trailblazer/files/trailblazer-0.9-makefile.patch b/games-arcade/trailblazer/files/trailblazer-0.9-makefile.patch
new file mode 100644
index 000000000000..70c7cdd90f26
--- /dev/null
+++ b/games-arcade/trailblazer/files/trailblazer-0.9-makefile.patch
@@ -0,0 +1,19 @@
+--- a/Makefile
++++ b/Makefile
+@@ -3,13 +3,13 @@
+ #
+
+ sources = game.c main.c road.c map.c gfx.c
+-libs = `sdl-config --libs`
+-cflags = -O2 -Wall `sdl-config --cflags`
++libs = `sdl-config --libs` -lm
++cflags = $(CFLAGS) $(CPPFLAGS) -Wall `sdl-config --cflags`
+ version = 0.9
+ bdir = /tmp/trailblazer-$(version)
+
+ all:
+- $(CC) $(sources) -o trailblazer $(cflags) $(libs)
++ $(CC) $(LDFLAGS) $(sources) -o trailblazer $(cflags) $(libs)
+
+ install:
+ cp trailblazer /usr/bin