summaryrefslogtreecommitdiff
path: root/games-arcade/tomatoes
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/tomatoes')
-rw-r--r--games-arcade/tomatoes/Manifest7
-rw-r--r--games-arcade/tomatoes/files/tomatoes-1.55-c_str.patch24
-rw-r--r--games-arcade/tomatoes/files/tomatoes-1.55-gcc43.patch14
-rw-r--r--games-arcade/tomatoes/files/tomatoes-1.55-underlink.patch38
-rw-r--r--games-arcade/tomatoes/metadata.xml11
-rw-r--r--games-arcade/tomatoes/tomatoes-1.55-r2.ebuild62
6 files changed, 156 insertions, 0 deletions
diff --git a/games-arcade/tomatoes/Manifest b/games-arcade/tomatoes/Manifest
new file mode 100644
index 000000000000..d11ce04e52c5
--- /dev/null
+++ b/games-arcade/tomatoes/Manifest
@@ -0,0 +1,7 @@
+AUX tomatoes-1.55-c_str.patch 573 BLAKE2B eccedf249d78074ce6292d580ad71cf9ff9b55f70d03976f26225f144b06c090714c4815c925cfc425bd8094e28fb1e5d0a5bf3ed6a48b6400c892afc922a812 SHA512 fce01efcdea6f14c497b747158e03e57fc39f532ddad7f8da80d6c94be6e9ec6b46b43e908e96f9b3744029ff285699f72b91a73b21b3e213d7054bf4e14f927
+AUX tomatoes-1.55-gcc43.patch 278 BLAKE2B 6597c2e500add91cf58f3a45e88d26b684f90b6a7a4644063701958cd5ba9b7f2d7c296f4c0adbd7718e72fdfc0198cfb0531d256f4d6c37d2ac54afa8b39ae1 SHA512 b0f6e5c3468902f73b2f88327f510b726082af6ace75d15f1d72c95d7ff19cfefef5558f2cdb2e0cf363a80f3c624c912825a1abb251608577bd617972b88e1c
+AUX tomatoes-1.55-underlink.patch 977 BLAKE2B 15d602a7a1618e331a4fe62ee72c22ff91af47cd1dfbf11f6b7039d7e43599c97d9a79705091f65cf1f2be5adbc8d8ed11f0246a8386134bc5694de901302175 SHA512 c6b1fb64b0196f0eb6a6f0d6a779d437d09901737670f66309598a84706615e1c9e48e60a7f6db15ce10f9237c1bdf8589cec39c46a4659fd4fcb3fe39225aa8
+DIST tomatoes-linux-1.5.tar.bz2 8807421 BLAKE2B ee2128018d13d274b0ed5b27f9339b4e9d47a15753411c30d4174607c252d10d64a40e40b25454adb6f14ec96845b92cf9b0fe57b3bdcbbb70fe905ec0bf1c0e SHA512 517f592bb3c3fb43cb740c58011f06b7a71c96eaff74ce1088db8dbd4aafa3463bba516547cd010e9ef2ca947fd36962c3d13ece6e979cab8adf01ffa991c308
+DIST tomatoes-linux-src-1.55.tar.bz2 62947 BLAKE2B 22561900842dfe4cb56128ddaf471fac56a2c93b4c24ce3cca7045d10235ab60b81184c9617f9f4d10877df23e6db0d5abc0dc032d38788993daab1a2c49ab1e SHA512 b5a6287659746179f0418630c55d34dc34897b532687007386b0b540ec728cc2492813f0d454314994a26a3629a24c802630085f64b969d1e6ea9ec936f5fe35
+EBUILD tomatoes-1.55-r2.ebuild 1590 BLAKE2B 8fcbf3ecad477c5f4e3d80082be96ee75f951233d7be70f7538692ccc91e737e55cfdb50968bdde922f579009a35e9e6ed6da21928af30e39298e74368b1aa4d SHA512 253966b1037eeb4e4143ed467f93e18df6eda3e0cb89a8a4e462b71925d72aff3faba5b685bb18b4a6be03173e200ca43f2c4fe6c6f48e764dc9bde98e07a068
+MISC metadata.xml 331 BLAKE2B 312d2ef06020a89fa08e79d82b22727eff32e689182f3f142bbc788555d2b05ddf93414a616deff188bc6d2ae35561da8fd832c2541c404d6136da144950c5b9 SHA512 adee588bcc930244c19ea9a3ac34b70c3afbbbed2b68d61289742fd7ca3d97eae5724cef90d350a4e5b8ff8b594f8d25fc1a5fbc672459034d0a492bb155223d
diff --git a/games-arcade/tomatoes/files/tomatoes-1.55-c_str.patch b/games-arcade/tomatoes/files/tomatoes-1.55-c_str.patch
new file mode 100644
index 000000000000..dd6927e54153
--- /dev/null
+++ b/games-arcade/tomatoes/files/tomatoes-1.55-c_str.patch
@@ -0,0 +1,24 @@
+--- src/config.cpp.orig 2004-09-27 11:35:48.000000000 +0200
++++ src/config.cpp 2006-02-13 00:00:01.000000000 +0100
+@@ -78,6 +78,7 @@
+ // makefile.
+ char *get_config_location(bool write) {
+ #ifdef LINUX
++ static char *config_path = NULL;
+ // Get the path to the config file
+ string tmp = get_tomatoes_dir() + "config.cfg";
+
+@@ -90,8 +91,11 @@
+ }
+ fclose(ftest);
+ }
+-
+- return (char*)tmp.c_str();
++ if (!config_path) {
++ config_path = new char[tmp.length()+1];
++ strcpy(config_path,tmp.c_str());
++ }
++ return config_path;
+ #endif
+
+ // Return the CONFIG_DIR
diff --git a/games-arcade/tomatoes/files/tomatoes-1.55-gcc43.patch b/games-arcade/tomatoes/files/tomatoes-1.55-gcc43.patch
new file mode 100644
index 000000000000..cd85e31e5936
--- /dev/null
+++ b/games-arcade/tomatoes/files/tomatoes-1.55-gcc43.patch
@@ -0,0 +1,14 @@
+--- src/config.cpp
++++ src/config.cpp
+@@ -27,8 +27,9 @@
+
+ *************************************************************************/
+
+-#include <stdio.h>
+-#include <stdlib.h>
++#include <cstring>
++#include <cstdio>
++#include <cstdlib>
+ #include "config.h"
+ #include "init.h"
+
diff --git a/games-arcade/tomatoes/files/tomatoes-1.55-underlink.patch b/games-arcade/tomatoes/files/tomatoes-1.55-underlink.patch
new file mode 100644
index 000000000000..c028c79ba4a7
--- /dev/null
+++ b/games-arcade/tomatoes/files/tomatoes-1.55-underlink.patch
@@ -0,0 +1,38 @@
+--- makefile.old 2011-06-18 17:35:38.947020335 +0200
++++ makefile 2011-06-18 17:37:42.337811088 +0200
+@@ -48,7 +47,7 @@
+ LDFLAGS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU -pg
+ else
+ CFLAGS = -MMD -O3 -march=$(MARCH) -Wall $(SDL_FLAGS)
+-LDFLAGS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU -s
++LDLIBS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU -lm
+ endif
+ endif
+
+@@ -58,7 +57,7 @@
+ OBJS := $(subst src/,obj/,$(OBJS))
+
+ # Include directories
+-INCLUDES = -I./include
++INCLUDES = -I./include $(SDL_FLAGS)
+
+
+ # Targets
+@@ -69,7 +68,7 @@
+ -include $(DEPS)
+
+ $(TARGET): $(OBJS)
+- $(CC) -o $(TARGET) $(OBJS) $(LDFLAGS)
++ $(CXX) -o $(TARGET) $(OBJS) $(LDFLAGS) $(LDLIBS)
+
+ clean:
+ rm -f $(OBJS) $(TARGET)
+@@ -80,7 +79,7 @@
+ rebuild: veryclean all
+
+ obj/%.o: src/%.cpp
+- $(CC) $(CFLAGS) $(INCLUDES) $(DIR_DEFINES) -c $< -o $@
++ $(CXX) $(CXXFLAGS) $(INCLUDES) $(DIR_DEFINES) -c $< -o $@
+
+ # Compress the exe with UPX
+ compress: $(TARGET)
diff --git a/games-arcade/tomatoes/metadata.xml b/games-arcade/tomatoes/metadata.xml
new file mode 100644
index 000000000000..b774279148e4
--- /dev/null
+++ b/games-arcade/tomatoes/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">tomatoes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-arcade/tomatoes/tomatoes-1.55-r2.ebuild b/games-arcade/tomatoes/tomatoes-1.55-r2.ebuild
new file mode 100644
index 000000000000..dd5658f861bf
--- /dev/null
+++ b/games-arcade/tomatoes/tomatoes-1.55-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DATA_PV=1.5
+DESCRIPTION="How many tomatoes can you smash in ten short minutes?"
+HOMEPAGE="http://tomatoes.sourceforge.net/about.html"
+SRC_URI="mirror://sourceforge/tomatoes/tomatoes-linux-src-${PV}.tar.bz2
+ mirror://sourceforge/tomatoes/tomatoes-linux-${DATA_PV}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ mv ../tomatoes-1.5/* . || die "mv failed"
+ mv icon.png ${PN}.png
+
+ epatch \
+ "${FILESDIR}"/${P}-c_str.patch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+
+ sed -i \
+ -e "/^MPKDIR = /s:./:${GAMES_DATADIR}/${PN}/:" \
+ -e "/^MUSICDIR = /s:./music/:${GAMES_DATADIR}/${PN}/music/:" \
+ -e "/^HISCOREDIR = /s:./:${GAMES_STATEDIR}/${PN}/:" \
+ -e "/^CONFIGDIR = /s:./:${GAMES_SYSCONFDIR}/${PN}/:" \
+ -e "/^OVERRIDEDIR = /s:./data/:${GAMES_DATADIR}/${PN}/data/:" \
+ makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ dogamesbin tomatoes
+ dodoc README README-src
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r tomatoes.mpk music
+
+ doicon ${PN}.png
+ make_desktop_entry tomatoes "I Have No Tomatoes"
+
+ dodir "${GAMES_STATEDIR}"/${PN}
+ touch "${D}${GAMES_STATEDIR}"/${PN}/hiscore.lst || die "touch failed"
+ fperms 660 "${GAMES_STATEDIR}"/${PN}/hiscore.lst
+
+ insinto "${GAMES_SYSCONFDIR}"/${PN}
+ doins config.cfg
+
+ prepgamesdirs
+}