summaryrefslogtreecommitdiff
path: root/games-arcade/syobon/syobon-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/syobon/syobon-1.0.1.ebuild')
-rw-r--r--games-arcade/syobon/syobon-1.0.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-arcade/syobon/syobon-1.0.1.ebuild b/games-arcade/syobon/syobon-1.0.1.ebuild
new file mode 100644
index 000000000000..46d14da04294
--- /dev/null
+++ b/games-arcade/syobon/syobon-1.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit games
+
+MY_P="${PN}_${PV}_src"
+
+DESCRIPTION="Syobon Action (also known as Cat Mario or Neko Mario)"
+HOMEPAGE="http://zapek.com/?p=189"
+SRC_URI="http://download.zapek.com/software/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[sound,video,joystick]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer[vorbis]"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ emake GAMEDATA="${GAMES_DATADIR}/${PN}"
+}
+
+src_install() {
+ dogamesbin ${PN}
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r BGM SE res
+ dodoc README.txt
+ prepgamesdirs
+}