summaryrefslogtreecommitdiff
path: root/games-arcade/stardork/stardork-0.7-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/stardork/stardork-0.7-r1.ebuild')
-rw-r--r--games-arcade/stardork/stardork-0.7-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-arcade/stardork/stardork-0.7-r1.ebuild b/games-arcade/stardork/stardork-0.7-r1.ebuild
new file mode 100644
index 000000000000..d2458f6571f1
--- /dev/null
+++ b/games-arcade/stardork/stardork-0.7-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="An ncurses-based space shooter"
+HOMEPAGE="http://stardork.sourceforge.net/"
+SRC_URI="mirror://sourceforge/stardork/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ rm -f Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="$(pkg-config ncurses --libs)" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ einstalldocs
+}