summaryrefslogtreecommitdiff
path: root/games-arcade/snake3d/snake3d-0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/snake3d/snake3d-0.9.ebuild')
-rw-r--r--games-arcade/snake3d/snake3d-0.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-arcade/snake3d/snake3d-0.9.ebuild b/games-arcade/snake3d/snake3d-0.9.ebuild
new file mode 100644
index 000000000000..bfa44607f886
--- /dev/null
+++ b/games-arcade/snake3d/snake3d-0.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+EAPI=5
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="variant of the snake game"
+HOMEPAGE="https://sourceforge.net/projects/worms3d/"
+SRC_URI="mirror://sourceforge/worms3d/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/sdl-net
+ virtual/opengl
+ media-libs/freeglut
+ virtual/glu
+ media-libs/libsdl"
+RDEPEND="${DEPEND}"
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-amd64.patch \
+ "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ emake CXX=$(tc-getCXX) -C src snake3d.linux
+}
+
+src_install() {
+ dogamesbin ${PN}
+ dodoc ChangeLog README TODO
+ prepgamesdirs
+}