summaryrefslogtreecommitdiff
path: root/games-arcade/skystreets/skystreets-0.2.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/skystreets/skystreets-0.2.4.ebuild')
-rw-r--r--games-arcade/skystreets/skystreets-0.2.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-arcade/skystreets/skystreets-0.2.4.ebuild b/games-arcade/skystreets/skystreets-0.2.4.ebuild
new file mode 100644
index 000000000000..405cb2fa532b
--- /dev/null
+++ b/games-arcade/skystreets/skystreets-0.2.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A remake of the old DOS game Skyroads"
+HOMEPAGE="http://freecode.com/projects/skystreets"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[opengl,video]
+ media-libs/sdl-image"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gl.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_install() {
+ default
+ newicon gfx/sunscene.png ${PN}.png
+ make_desktop_entry ${PN} SkyStreets
+ prepgamesdirs
+}