summaryrefslogtreecommitdiff
path: root/games-arcade/primateplunge/primateplunge-1.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/primateplunge/primateplunge-1.1-r1.ebuild')
-rw-r--r--games-arcade/primateplunge/primateplunge-1.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-arcade/primateplunge/primateplunge-1.1-r1.ebuild b/games-arcade/primateplunge/primateplunge-1.1-r1.ebuild
new file mode 100644
index 000000000000..211d2a7caa24
--- /dev/null
+++ b/games-arcade/primateplunge/primateplunge-1.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="Help poor Monkey navigate his way down through treacherous areas"
+HOMEPAGE="http://www.aelius.com/primateplunge/"
+SRC_URI="http://www.aelius.com/${PN}/${P}.tar.gz"
+
+LICENSE="Primate-Plunge"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+RESTRICT="mirror bindist" #465850
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-AC_SUBST.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README TIPS
+ newicon graphics/idle.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Primate Plunge" /usr/share/pixmaps/${PN}.bmp
+ prepgamesdirs
+}