summaryrefslogtreecommitdiff
path: root/games-arcade/notpacman/notpacman-1.0.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/notpacman/notpacman-1.0.4-r1.ebuild')
-rw-r--r--games-arcade/notpacman/notpacman-1.0.4-r1.ebuild28
1 files changed, 7 insertions, 21 deletions
diff --git a/games-arcade/notpacman/notpacman-1.0.4-r1.ebuild b/games-arcade/notpacman/notpacman-1.0.4-r1.ebuild
index 26472c8d2172..de7d45a2d9cd 100644
--- a/games-arcade/notpacman/notpacman-1.0.4-r1.ebuild
+++ b/games-arcade/notpacman/notpacman-1.0.4-r1.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit desktop eutils gnome2-utils
+inherit desktop wrapper xdg
-DESCRIPTION="A mashup of \"Not\" and \"Pacman\""
+DESCRIPTION="Mashup of \"Not\" and \"Pacman\""
HOMEPAGE="https://stabyourself.net/notpacman/"
SRC_URI="https://stabyourself.net/dl.php?file=notpacman-1004/notpacman-linux.zip -> ${P}.zip
https://dev.gentoo.org/~chewi/distfiles/${PN}.png"
+S="${WORKDIR}"
LICENSE="WTFPL-2"
SLOT="0"
@@ -16,11 +17,8 @@ KEYWORDS="~amd64 ~x86"
LVSLOT="0.7"
RDEPEND=">=games-engines/love-0.7.2:${LVSLOT}
- media-libs/devil[png]
-"
-DEPEND="app-arch/unzip"
-
-S="${WORKDIR}"
+ media-libs/devil[png]"
+BDEPEND="app-arch/unzip"
src_install() {
local dir=/usr/share/love/${PN}
@@ -34,15 +32,3 @@ src_install() {
make_wrapper ${PN} "love-${LVSLOT} ${PN}.love" "${dir}"
make_desktop_entry ${PN}
}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}