summaryrefslogtreecommitdiff
path: root/games-arcade/notpacman/notpacman-1.0.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/notpacman/notpacman-1.0.4-r1.ebuild')
-rw-r--r--games-arcade/notpacman/notpacman-1.0.4-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-arcade/notpacman/notpacman-1.0.4-r1.ebuild b/games-arcade/notpacman/notpacman-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..d8e99a5e1408
--- /dev/null
+++ b/games-arcade/notpacman/notpacman-1.0.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils gnome2-utils
+
+DESCRIPTION="A mashup of \"Not\" and \"Pacman\""
+HOMEPAGE="http://stabyourself.net/notpacman/"
+SRC_URI="http://stabyourself.net/dl.php?file=notpacman-1004/notpacman-linux.zip -> ${P}.zip
+ https://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+LVSLOT="0.7"
+RDEPEND=">=games-engines/love-0.7.2:${LVSLOT}
+ media-libs/devil[png]
+"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install() {
+ local dir=/usr/share/love/${PN}
+
+ exeinto "${dir}"
+ newexe not_pacman.love ${PN}.love
+
+ einstalldocs
+
+ doicon -s 32 "${DISTDIR}"/${PN}.png
+ make_wrapper ${PN} "love-${LVSLOT} ${PN}.love" "${dir}"
+ make_desktop_entry ${PN}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}