summaryrefslogtreecommitdiff
path: root/games-arcade/late/late-0.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/late/late-0.1.0.ebuild')
-rw-r--r--games-arcade/late/late-0.1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-arcade/late/late-0.1.0.ebuild b/games-arcade/late/late-0.1.0.ebuild
new file mode 100644
index 000000000000..3dd5bba084e7
--- /dev/null
+++ b/games-arcade/late/late-0.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A game, similar to Barrack by Ambrosia Software"
+HOMEPAGE="http://late.sourceforge.net/"
+SRC_URI="mirror://sourceforge/late/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image[jpeg]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
+ sed -i \
+ -e "/chown/d" \
+ Makefile.in \
+ || die "sed failed"
+}
+
+src_install () {
+ default
+ newicon graphics/latebg2.jpg ${PN}.jpg
+ make_desktop_entry late Late /usr/share/pixmaps/${PN}.jpg
+ prepgamesdirs
+}