summaryrefslogtreecommitdiff
path: root/games-arcade/gnake/gnake-0.94b.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/gnake/gnake-0.94b.ebuild')
-rw-r--r--games-arcade/gnake/gnake-0.94b.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-arcade/gnake/gnake-0.94b.ebuild b/games-arcade/gnake/gnake-0.94b.ebuild
new file mode 100644
index 000000000000..6ebda89f169c
--- /dev/null
+++ b/games-arcade/gnake/gnake-0.94b.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit games
+
+DESCRIPTION="An ncurses-based Nibbles clone"
+HOMEPAGE="http://lightless.org/gnake"
+SRC_URI="mirror://gentoo/Gnake.${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ emake LDLIBS="$(pkg-config ncurses --libs)" gnake
+}
+
+src_install() {
+ dogamesbin gnake
+ dodoc README
+ prepgamesdirs
+}