summaryrefslogtreecommitdiff
path: root/games-arcade/criticalmass/files
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/criticalmass/files')
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.2-cflags.patch27
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.2-flags.patch24
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.2-gcc43.patch99
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.2-libpng.patch28
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.2-libpng14.patch11
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.2-libpng15.patch31
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.2-system-curl.patch (renamed from games-arcade/criticalmass/files/criticalmass-1.0.2-system_curl.patch)30
7 files changed, 83 insertions, 167 deletions
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.2-cflags.patch b/games-arcade/criticalmass/files/criticalmass-1.0.2-cflags.patch
deleted file mode 100644
index 0d9063c37538..000000000000
--- a/games-arcade/criticalmass/files/criticalmass-1.0.2-cflags.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/configure.in.orig 2011-07-20 11:23:19.849122541 -0400
-+++ b/configure.in 2011-07-20 11:24:28.169713094 -0400
-@@ -35,9 +35,6 @@
- AM_CONDITIONAL(APPLE,test "x$TARGET" = xAPPLE)
- AM_CONDITIONAL(WIN32,test "x$TARGET" = xWIN32)
-
--CFLAGS=""
--CXXFLAGS=""
--
- if test "x$GCC" = xyes; then
- CFLAGS="$CFLAGS -W -Wall"
- CXXFLAGS="$CXXFLAGS -W -Wall -fno-exceptions"
-@@ -51,14 +48,6 @@
- CXXFLAGS="$CXXFLAGS -g"
- fi
-
--AC_ARG_ENABLE(optimize,
--[ --enable-optimize=level Enable optimization [default=2]],
-- enable_optmize=$enableval, enable_optimize=2)
--if test "x$enable_optimize" != "xno" ; then
-- CFLAGS="$CFLAGS -O$enable_optimize"
-- CXXFLAGS="$CXXFLAGS -O$enable_optimize"
--fi
--
- AC_ARG_ENABLE(dyngl,
- [ --enable-dyngl Load GL library dynamically [default=off]],
- enable_dyngl=$enableval, enable_dyngl=off)
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.2-flags.patch b/games-arcade/criticalmass/files/criticalmass-1.0.2-flags.patch
new file mode 100644
index 000000000000..5677211c78a2
--- /dev/null
+++ b/games-arcade/criticalmass/files/criticalmass-1.0.2-flags.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/375739
+--- a/configure.in
++++ b/configure.in
+@@ -24,2 +24,3 @@
+ AC_PROG_RANLIB
++AM_PROG_AR
+
+@@ -37,5 +38,2 @@
+
+-CFLAGS=""
+-CXXFLAGS=""
+-
+ if test "x$GCC" = xyes; then
+@@ -52,10 +50,2 @@
+ fi
+-
+-AC_ARG_ENABLE(optimize,
+-[ --enable-optimize=level Enable optimization [default=2]],
+- enable_optmize=$enableval, enable_optimize=2)
+-if test "x$enable_optimize" != "xno" ; then
+- CFLAGS="$CFLAGS -O$enable_optimize"
+- CXXFLAGS="$CXXFLAGS -O$enable_optimize"
+-fi
+
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.2-gcc43.patch b/games-arcade/criticalmass/files/criticalmass-1.0.2-gcc43.patch
index e57c11f5af28..82207f52aec0 100644
--- a/games-arcade/criticalmass/files/criticalmass-1.0.2-gcc43.patch
+++ b/games-arcade/criticalmass/files/criticalmass-1.0.2-gcc43.patch
@@ -1,101 +1,46 @@
---- CriticalMass-1.0.0.orig/tinyxml/tinyxml.cpp 2003-03-03 03:34:58.000000000 +0100
-+++ CriticalMass-1.0.0/tinyxml/tinyxml.cpp 2008-04-18 19:40:35.000000000 +0200
-@@ -21,10 +21,12 @@
- distribution.
- */
-
- #include "tinyxml.h"
+https://bugs.gentoo.org/218299
+--- a/tinyxml/tinyxml.cpp
++++ b/tinyxml/tinyxml.cpp
+@@ -25,2 +25,4 @@
+#include <cstring>
+
- TiXmlNode::TiXmlNode( NodeType _type )
- {
- parent = 0;
- type = _type;
---- CriticalMass-1.0.0.orig/tinyxml/tinyxml.h 2003-03-03 03:34:58.000000000 +0100
-+++ CriticalMass-1.0.0/tinyxml/tinyxml.h 2008-04-18 19:40:35.000000000 +0200
-@@ -28,10 +28,11 @@
- #ifdef _MSC_VER
- #pragma warning( disable : 4530 )
- #pragma warning( disable : 4786 )
- #endif
+--- a/tinyxml/tinyxml.h
++++ b/tinyxml/tinyxml.h
+@@ -32,2 +32,3 @@
+#include <cstdlib>
#include <string>
- #include <stdio.h>
- #include <assert.h>
-
- class TiXmlDocument;
---- CriticalMass-1.0.0.orig/tinyxml/tinyxmlparser.cpp 2003-03-03 03:34:58.000000000 +0100
-+++ CriticalMass-1.0.0/tinyxml/tinyxmlparser.cpp 2008-04-18 19:40:35.000000000 +0200
-@@ -23,10 +23,12 @@
-
-
- #include "tinyxml.h"
- #include <ctype.h>
+--- a/tinyxml/tinyxmlparser.cpp
++++ b/tinyxml/tinyxmlparser.cpp
+@@ -27,2 +27,4 @@
+#include <cstring>
+
const char* TiXmlBase::SkipWhiteSpace( const char* p )
- {
- while ( p && *p &&
- ( isspace( *p ) || *p == '\n' || *p == '\r' ) )
- p++;
---- CriticalMass-1.0.0.orig/utils/ResourceManager.cpp 2005-01-02 03:59:29.000000000 +0100
-+++ CriticalMass-1.0.0/utils/ResourceManager.cpp 2008-04-18 19:40:35.000000000 +0200
-@@ -20,10 +20,12 @@
- #include <ResourceManager.hpp>
- #include <FindHash.hpp>
- #include <Endian.hpp>
- #include <WalkDirectory.hpp>
+--- a/utils/ResourceManager.cpp
++++ b/utils/ResourceManager.cpp
+@@ -24,2 +24,4 @@
+#include <cstring>
+
#ifdef WIN32
- const char PATH_SEPERATOR = '\\';
- #else
- const char PATH_SEPERATOR = '/';
- #endif
---- CriticalMass-1.0.0.orig/utils/Value.hpp 2004-12-18 03:41:24.000000000 +0100
-+++ CriticalMass-1.0.0/utils/Value.hpp 2008-04-18 19:40:35.000000000 +0200
-@@ -13,10 +13,11 @@
- // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
- //
- #ifndef _Value_hpp_
- #define _Value_hpp_
+--- a/utils/Value.hpp
++++ b/utils/Value.hpp
+@@ -17,2 +17,3 @@
+#include <cstdlib>
#include <stdio.h>
- #include <string>
-
- #include <Trace.hpp>
-
---- CriticalMass-1.0.0.orig/utils/zStreamBufferImplZLib.cpp 2005-07-31 22:06:14.000000000 +0200
-+++ CriticalMass-1.0.0/utils/zStreamBufferImplZLib.cpp 2008-04-18 19:40:35.000000000 +0200
-@@ -10,10 +10,11 @@
- //
- // This program is distributed in the hope that it will be useful, but WITHOUT
- // ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
- // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
+--- a/utils/zStream.cpp
++++ b/utils/zStream.cpp
+@@ -14,2 +14,3 @@
//
+#include <cstdlib>
#include <Trace.hpp>
- #include <zStreamBufferImplZLib.hpp>
-
- bool ziStreamBufferImplZLib::init( void)
- {
---- CriticalMass-1.0.0.orig/utils/zStream.cpp 2005-07-31 22:06:14.000000000 +0200
-+++ CriticalMass-1.0.0/utils/zStream.cpp 2008-04-18 19:40:35.000000000 +0200
-@@ -10,10 +10,11 @@
- //
- // This program is distributed in the hope that it will be useful, but WITHOUT
- // ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
- // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
+--- a/utils/zStreamBufferImplZLib.cpp
++++ b/utils/zStreamBufferImplZLib.cpp
+@@ -14,2 +14,3 @@
//
+#include <cstdlib>
#include <Trace.hpp>
- #include <Endian.hpp>
- #include <zStream.hpp>
- #include <zStreamBufferImplLZMA.hpp>
- #include <zStreamBufferImplZLib.hpp>
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng.patch b/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng.patch
new file mode 100644
index 000000000000..c2ea21bb2d63
--- /dev/null
+++ b/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/206258
+https://bugs.gentoo.org/383207
+--- a/configure.in
++++ b/configure.in
+@@ -101,3 +101,3 @@
+ CXXFLAGS="$CXXFLAGS -I/usr/X11R6/include"
+- AC_CHECK_LIB(png12, main,, AC_MSG_ERROR(libpng is needed))
++ AC_CHECK_LIB(png, main,, AC_MSG_ERROR(libpng is needed))
+ AC_CHECK_LIB(z, main,, AC_MSG_ERROR(libz is needed))
+--- a/game/main.cpp
++++ b/game/main.cpp
+@@ -30,2 +30,4 @@
+
++#include <zlib.h>
++
+ void migrateConfig( void)
+--- a/utilssdl/PNG.cpp
++++ b/utilssdl/PNG.cpp
+@@ -47,3 +47,3 @@
+
+- check = fwrite( data, 1, length, (FILE *)(png->io_ptr));
++ check = fwrite( data, 1, length, (FILE *)(png_get_io_ptr(png)));
+ if( check != length)
+@@ -74,3 +74,3 @@
+
+- if( setjmp(_png->jmpbuf))
++ if( setjmp(png_jmpbuf(_png)))
+ {
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng14.patch b/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng14.patch
deleted file mode 100644
index f8a0eec2ad57..000000000000
--- a/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng14.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/configure.in
-+++ b/configure.in
-@@ -99,7 +99,7 @@ if test "x$TARGET" = xWIN32; then
- else
- LIBS="-L/usr/local/lib -L/usr/X11R6/lib $LIBS"
- CXXFLAGS="$CXXFLAGS -I/usr/X11R6/include"
-- AC_CHECK_LIB(png12, main,, AC_MSG_ERROR(libpng is needed))
-+ AC_CHECK_LIB(png, main,, AC_MSG_ERROR(libpng is needed))
- AC_CHECK_LIB(z, main,, AC_MSG_ERROR(libz is needed))
- if test "x$TARGET" = xUNIX; then
- if test "x$enable_dyngl" = xoff; then
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng15.patch b/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng15.patch
deleted file mode 100644
index dbdfc9f32275..000000000000
--- a/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng15.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/game/main.cpp
-+++ b/game/main.cpp
-@@ -28,6 +28,8 @@
- #include <sys/stat.h>
- #include <sys/types.h>
-
-+#include <zlib.h>
-+
- void migrateConfig( void)
- {
- //if onlineCheck is not set, default it to true
---- a/utilssdl/PNG.cpp
-+++ b/utilssdl/PNG.cpp
-@@ -45,7 +45,7 @@
- {
- png_size_t check;
-
-- check = fwrite( data, 1, length, (FILE *)(png->io_ptr));
-+ check = fwrite( data, 1, length, (FILE *)(png_get_io_ptr(png)));
- if( check != length)
- {
- png_error( png, "Write Error");
-@@ -72,7 +72,7 @@
- return false;
- }
-
-- if( setjmp(_png->jmpbuf))
-+ if( setjmp(png_jmpbuf(_png)))
- {
- fclose( fp);
- png_destroy_write_struct(&_png, (png_infopp)NULL);
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.2-system_curl.patch b/games-arcade/criticalmass/files/criticalmass-1.0.2-system-curl.patch
index 1ab1a2d5ce52..084efbc05cf2 100644
--- a/games-arcade/criticalmass/files/criticalmass-1.0.2-system_curl.patch
+++ b/games-arcade/criticalmass/files/criticalmass-1.0.2-system-curl.patch
@@ -1,33 +1,21 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -6,3 +6,3 @@
+ ## Any directories that you want built and installed should go here.
+-SUBDIRS = curl tinyxml utils utilssdl utilsgl tools data game
++SUBDIRS = tinyxml utils utilssdl utilsgl tools data game
+
--- a/configure.in
+++ b/configure.in
-@@ -115,8 +115,6 @@ fi
- AC_CHECK_LIB(m, sin,,
- AC_MSG_ERROR(libm is needed))
+@@ -121,4 +121,2 @@
-AC_CONFIG_SUBDIRS(curl)
-
AC_OUTPUT(Makefile utils/Makefile utilssdl/Makefile utilsgl/Makefile game/Makefile tools/Makefile data/Makefile data/music/Makefile tinyxml/Makefile)
-
- echo "Configuration:
--- a/game/Makefile.am
+++ b/game/Makefile.am
-@@ -41,7 +41,7 @@ critter_SOURCES = \
- main.cpp
-
+@@ -43,3 +43,3 @@
LDADD = \
- ../curl/lib/libcurl.a \
+ -lcurl \
../utils/libutils.a \
- ../utilssdl/libutilssdl.a \
- ../utilsgl/libutilsgl.a \
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -4,7 +4,7 @@
- AUTOMAKE_OPTIONS = 1.4
-
- ## Any directories that you want built and installed should go here.
--SUBDIRS = curl tinyxml utils utilssdl utilsgl tools data game
-+SUBDIRS = tinyxml utils utilssdl utilsgl tools data game
-
- ## Any directories you want a part of the distribution should be listed
- ## here, as well as have a Makefile generated at the end of configure.in