summaryrefslogtreecommitdiff
path: root/games-arcade/cob/cob-0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/cob/cob-0.9.ebuild')
-rw-r--r--games-arcade/cob/cob-0.9.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-arcade/cob/cob-0.9.ebuild b/games-arcade/cob/cob-0.9.ebuild
new file mode 100644
index 000000000000..a8af1488cc0a
--- /dev/null
+++ b/games-arcade/cob/cob-0.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Cruising on Broadway: a painting-type game"
+HOMEPAGE="http://www.autismuk.freeserve.co.uk/"
+SRC_URI="http://www.autismuk.freeserve.co.uk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[joystick,sound,video]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}