summaryrefslogtreecommitdiff
path: root/games-arcade/blobby/blobby-1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/blobby/blobby-1.0-r1.ebuild')
-rw-r--r--games-arcade/blobby/blobby-1.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-arcade/blobby/blobby-1.0-r1.ebuild b/games-arcade/blobby/blobby-1.0-r1.ebuild
new file mode 100644
index 000000000000..0044ddcffb2d
--- /dev/null
+++ b/games-arcade/blobby/blobby-1.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop
+
+DESCRIPTION="Beach ball game with blobs of goo"
+HOMEPAGE="https://sourceforge.net/projects/blobby/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}2-linux-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-games/physfs-2[zip]
+ media-libs/libsdl2[sound,joystick,opengl,video]
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ app-arch/zip
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-compile.patch
+ "${FILESDIR}"/${P}-paths.patch
+ "${FILESDIR}"/${P}-install.patch
+)
+
+src_install() {
+ cmake_src_install
+
+ newicon data/Icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Blobby Volley" /usr/share/pixmaps/${PN}.bmp
+}