summaryrefslogtreecommitdiff
path: root/games-arcade/balloonchase/files
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/balloonchase/files')
-rw-r--r--games-arcade/balloonchase/files/balloonchase-0.9.6-gentoo.patch (renamed from games-arcade/balloonchase/files/0.9.6-gentoo.patch)51
1 files changed, 11 insertions, 40 deletions
diff --git a/games-arcade/balloonchase/files/0.9.6-gentoo.patch b/games-arcade/balloonchase/files/balloonchase-0.9.6-gentoo.patch
index ff232693422b..c847f0677660 100644
--- a/games-arcade/balloonchase/files/0.9.6-gentoo.patch
+++ b/games-arcade/balloonchase/files/balloonchase-0.9.6-gentoo.patch
@@ -1,26 +1,18 @@
--- a/Makefile
+++ b/Makefile
-@@ -1,4 +1,3 @@
+@@ -1,2 +1 @@
-LDFLAGS= -lSDL -lpthread -s
CFLAGS= -Wall # -DDEBUG
- PKG_BCDIR=balloonchase-`cat src/ver`
- PKG_BCVER=`cat src/ver`
-@@ -9,8 +8,8 @@
- clean:
- rm balloonchase src/*.o
+@@ -11,4 +10,4 @@
main: src/main.c
- g++ -c -o src/main.o `sdl-config --cflags` src/main.c
- g++ -o balloonchase src/main.o `sdl-config --libs`
-+ g++ $(CXXFLAGS) -c -o src/main.o `sdl-config --cflags` src/main.c
-+ g++ $(LDFLAGS) -o balloonchase src/main.o `sdl-config --libs`
++ $(CXX) $(CXXFLAGS) -c -o src/main.o `$(PKG_CONFIG) --cflags sdl` src/main.c
++ $(CXX) $(LDFLAGS) -o balloonchase src/main.o `$(PKG_CONFIG) --libs sdl`
pkg:
- @echo $(PKG_BCVERSION) >VERSION
- rm balloonchase src/*.o
--- a/src/main.c
+++ b/src/main.c
-@@ -333,47 +333,47 @@
-
- int InitImages()
+@@ -335,35 +335,35 @@
{
- back = SDL_LoadBMP("images/back.bmp");
+ back = SDL_LoadBMP("GENTOODIR/images/back.bmp");
@@ -71,8 +63,7 @@
- font2 = SDL_LoadBMP("images/font.bmp");
+ font2 = SDL_LoadBMP("GENTOODIR/images/font.bmp");
font = SDL_CreateRGBSurface(SDL_SWSURFACE, 1288, 100, 32, 0xFF000000, 0x00FF0000, 0x0000FF00, 0x000000FF);
- SDL_SetColorKey(font, SDL_SRCCOLORKEY, SDL_MapRGB(font->format, 0x00, 0x00, 0x00));
- DrawIMG (font, font2, 0, 0);
+@@ -372,6 +372,6 @@
- blobtrox = SDL_LoadBMP("images/blobtrox.bmp");
+ blobtrox = SDL_LoadBMP("GENTOODIR/images/blobtrox.bmp");
@@ -81,27 +72,17 @@
- balloonchase = SDL_LoadBMP("images/balloonchase.bmp");
+ balloonchase = SDL_LoadBMP("GENTOODIR/images/balloonchase.bmp");
- TMP = SDL_CreateRGBSurface(SDL_SWSURFACE, 259, 200, 32, 0xFF000000, 0x00FF0000, 0x0000FF00, 0x000000FF);
- blursurface = SDL_CreateRGBSurface(SDL_SWSURFACE, 640, 480, 32, 0x00000000, 0x00000000, 0x00000000, 0x00000000);
-@@ -578,7 +578,7 @@
-
- void createdat(int winsneed, int option_wave_effect)
+@@ -580,3 +580,3 @@
{
- FILE *OPTFILE=fopen ("balloonchase.dat", "w+");
+ FILE *OPTFILE=fopen (".balloonchaserc", "w+");
char datmsg[60];
- sprintf (datmsg, "Balloon Chase settings file -- Do not edit manually!");
- char tmp2;
-@@ -588,52 +588,32 @@
- }
- fputc (winsneed, OPTFILE);
+@@ -590,3 +590,3 @@
fputc (option_wave_effect+2, OPTFILE);
- fprintf (stderr, "Saved configuration to balloonchase.dat\n");
+ fprintf (stderr, "Saved configuration to .balloonchaserc\n");
fclose (OPTFILE);
- }
-
- void checkfiles()
+@@ -596,42 +596,22 @@
{
- char found=0;
- #ifdef WIN32
@@ -161,23 +142,13 @@
+ createdat(2, 1);
+ }
}
-
- Uint32 rgb(Uint8 r, Uint8 g, Uint8 b)
-@@ -1257,7 +1237,7 @@
- SDL_WM_SetCaption ("Balloon Chase", 0);
- checkfiles();
+@@ -1259,3 +1239,3 @@
- FILE *OPTFILE=fopen ("balloonchase.dat", "r");
+ FILE *OPTFILE=fopen (".balloonchaserc", "r");
char datmsg[60];
- char varmistus[60];
-
-@@ -1275,7 +1255,7 @@
- {
- winsneeded=fgetc(OPTFILE);
+@@ -1277,3 +1257,3 @@
option_wave_effect=fgetc(OPTFILE)-2;
- fprintf (stderr, "Successfully loaded balloonchase.dat\n");
+ fprintf (stderr, "Successfully loaded .balloonchaserc\n");
}
- else
- {