summaryrefslogtreecommitdiff
path: root/games-arcade/aop/aop-0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/aop/aop-0.6.ebuild')
-rw-r--r--games-arcade/aop/aop-0.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-arcade/aop/aop-0.6.ebuild b/games-arcade/aop/aop-0.6.ebuild
new file mode 100644
index 000000000000..db9c230bc2bb
--- /dev/null
+++ b/games-arcade/aop/aop-0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Ambassador of Pain is a curses based game with only 64 lines of code"
+HOMEPAGE="http://raffi.at/view/code/aop"
+SRC_URI="http://www.raffi.at/code/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e "s#/usr/local/share#${GAMES_DATADIR}#" \
+ aop.c || die
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_install() {
+ dogamesbin aop
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins aop-level-*.txt
+ prepgamesdirs
+}