summaryrefslogtreecommitdiff
path: root/games-arcade/alienwave/files/alienwave-0.4.0-gentoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/alienwave/files/alienwave-0.4.0-gentoo.patch')
-rw-r--r--games-arcade/alienwave/files/alienwave-0.4.0-gentoo.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/games-arcade/alienwave/files/alienwave-0.4.0-gentoo.patch b/games-arcade/alienwave/files/alienwave-0.4.0-gentoo.patch
new file mode 100644
index 000000000000..bed5d38c0b8f
--- /dev/null
+++ b/games-arcade/alienwave/files/alienwave-0.4.0-gentoo.patch
@@ -0,0 +1,22 @@
+--- alienwave.orig/Makefile
++++ alienwave/Makefile
+@@ -1,9 +1,7 @@
+ # This file is part of Alienwave, a game by Alessandro Pira
+
+-CC = gcc
+ OBJS = main.o blit.o aliens.o xzarna.o fire.o shield.o levels.o util.o
+ # CFLAGS = -c -O2 -Wall -DDEBUG_LEV
+-CFLAGS = -c -O2 -Wall
+ LIB = -lncurses
+
+ # Uncomment this if you want random waves
+@@ -16,8 +14,7 @@
+
+
+ alienwave: $(OBJS)
+- $(CC) $(OBJS) $(LIB) -o alienwave
+- strip alienwave
++ $(CC) $(OBJS) $(LDFLAGS) $(LIB) -o alienwave
+
+ main.o: main.c
+