summaryrefslogtreecommitdiff
path: root/games-action
diff options
context:
space:
mode:
Diffstat (limited to 'games-action')
-rw-r--r--games-action/Manifest.gzbin13641 -> 13664 bytes
-rw-r--r--games-action/assault-android-cactus+/Manifest3
-rw-r--r--games-action/assault-android-cactus+/assault-android-cactus+-200507.ebuild51
-rw-r--r--games-action/assault-android-cactus+/metadata.xml8
-rw-r--r--games-action/heroes/Manifest6
-rw-r--r--games-action/heroes/files/heroes-0.21-compilation.patch48
-rw-r--r--games-action/heroes/files/heroes-0.21-cvs-segfault-fix.patch (renamed from games-action/heroes/files/0.21-cvs-segfault-fix.patch)0
-rw-r--r--games-action/heroes/files/heroes-0.21-gcc10.patch16
-rw-r--r--games-action/heroes/heroes-0.21-r2.ebuild42
-rw-r--r--games-action/rune/Manifest3
-rw-r--r--games-action/rune/metadata.xml40
-rw-r--r--games-action/rune/rune-1.07-r3.ebuild129
12 files changed, 155 insertions, 191 deletions
diff --git a/games-action/Manifest.gz b/games-action/Manifest.gz
index 13b199a97231..2e2145b2f21f 100644
--- a/games-action/Manifest.gz
+++ b/games-action/Manifest.gz
Binary files differ
diff --git a/games-action/assault-android-cactus+/Manifest b/games-action/assault-android-cactus+/Manifest
new file mode 100644
index 000000000000..7338e39ab3e3
--- /dev/null
+++ b/games-action/assault-android-cactus+/Manifest
@@ -0,0 +1,3 @@
+DIST AssaultAndroidCactus_linux_200507.zip 1075393925 BLAKE2B 8a4284c1d6fe07e4c9aaa33b387ba561f2a34c00fd3b3f3f237dfdb652ffbab3d7271ae5d55064e96ec97935160e6e6a51ae804d5faf629a9fc08854128470d9 SHA512 d09992af6f2d019423c47a847c4e497d09201d562b2cba6ae1c631397c695ceb2a8d8f232a38bcee2badf32aceb523067fb7843c1bb13070b54a58d2b988d23c
+EBUILD assault-android-cactus+-200507.ebuild 1258 BLAKE2B 67815daf369a2837b7fa080bb8a49c9d81599e9411fa5f732184ce2940952386db06ed6099c47b6ee9cbf7f678c40f7f56ebabe575f6b265b2d07706837489f4 SHA512 639b2054f972dbd17da24422e5039d9aa7978f680369a6d0451239221f9f5438097215188cb9502dffbdb272080d51130b511e5fc03f713a3cac497243931279
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-action/assault-android-cactus+/assault-android-cactus+-200507.ebuild b/games-action/assault-android-cactus+/assault-android-cactus+-200507.ebuild
new file mode 100644
index 000000000000..214b0d0a9be5
--- /dev/null
+++ b/games-action/assault-android-cactus+/assault-android-cactus+-200507.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop xdg
+
+MY_PN="cactus"
+DESCRIPTION="Arcade style twin stick shooter set in a vivid sci-fi universe"
+HOMEPAGE="http://www.assaultandroidcactus.com/"
+SRC_URI="AssaultAndroidCactus_linux_${PV}.zip"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ sys-libs/zlib
+ virtual/opengl
+"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+S="${WORKDIR}/AssaultAndroidCactus_linux"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/${PN%+}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_install() {
+ exeinto "${DIR}"
+ newexe ${MY_PN}.$(usex amd64 x86_64 x86) ${MY_PN}
+ make_wrapper ${PN} "${DIR}"/${MY_PN}
+
+ insinto "${DIR}"
+ doins -r ${MY_PN}_Data/
+ rm -r "${ED}/${DIR}"/${MY_PN}_Data/*/$(usex amd64 x86 x86_64) || die
+
+ # Some Unity games have a GUI launcher but this one doesn't use it.
+ rm "${ED}/${DIR}"/${MY_PN}_Data/Plugins/*/ScreenSelector.so || die
+
+ newicon -s 128 ${MY_PN}_Data/Resources/UnityPlayer.png ${PN}.png
+ make_desktop_entry ${PN} "Assault Android Cactus+"
+}
diff --git a/games-action/assault-android-cactus+/metadata.xml b/games-action/assault-android-cactus+/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-action/assault-android-cactus+/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-action/heroes/Manifest b/games-action/heroes/Manifest
index 632d40a7c078..7ac79048b74e 100644
--- a/games-action/heroes/Manifest
+++ b/games-action/heroes/Manifest
@@ -1,10 +1,12 @@
-AUX 0.21-cvs-segfault-fix.patch 551 BLAKE2B 0a09409c97d252878cb3841b6c6ab95b4dea3b91aa6c6b81d84adc263bcee1629e0f7856ef9ddda3ba718a02aec8beab3c16cab06a76192e7081ee8be9c447a5 SHA512 4ccce0f50a5f2128809d8fa759b4dcdd002443ecf6d35ebd72a46e1feb0461150535c462e674156c9f8550578ea4b66d3c87aee74c3bbdfe756a96caa54bdde1
AUX heroes-0.21-automake-1.12.patch 335 BLAKE2B 6c2d757313999dfce5d9fc4b2b4ded76bad6b89e45777910de8cef441590015fa37491594a6989a0da29fb70e636fc5b1c1a3bbba56bd371cb6ba1226d2620f7 SHA512 9c40b9b0bd4e82f3f9bd9b66c455e834bd1b2a91e79dd550fd4aada4ca1b6e2ecb55353f31cad1a021a28dfc3781afb1f040545bf8030b0e63b988708aae480d
+AUX heroes-0.21-compilation.patch 850 BLAKE2B d5a372906082794c686de7eb560a1f7da6790f73e7c5cb2cb4331fa8cf95999e4417c56e9043463452a1bd0e8d339fa0ff954e3de6d4f1ad7666e41b17443757 SHA512 d8214ddf3a9167a13eb51eeaa0b4c6f4e2d319c69a32d6ce77ca7ebbd19284312613d3d59c4393051ed1e8e119778e947f96e692e133bb0eae0e74e07fe1822a
+AUX heroes-0.21-cvs-segfault-fix.patch 551 BLAKE2B 0a09409c97d252878cb3841b6c6ab95b4dea3b91aa6c6b81d84adc263bcee1629e0f7856ef9ddda3ba718a02aec8beab3c16cab06a76192e7081ee8be9c447a5 SHA512 4ccce0f50a5f2128809d8fa759b4dcdd002443ecf6d35ebd72a46e1feb0461150535c462e674156c9f8550578ea4b66d3c87aee74c3bbdfe756a96caa54bdde1
+AUX heroes-0.21-gcc10.patch 528 BLAKE2B c14fc4995fbebce2a0053632e8f4392d265b6ed6ecc99f1e019e9f9c07f07392315593fe2f207acfb69b382ae22ae34bec2ff66531b1f4356503f3eb7285be35 SHA512 96c94fed186469d6c38fcf6fda400880a546e0d95bf26cb2725d9ec86b4732bd25c37de79d3f0b6830c199b3486966393704fe6710ac55ad85d89bbdd12e1967
AUX heroes-0.21-gcc4.patch 6016 BLAKE2B a99603890ca5f7c23ca3286faea125b31c6b2eb7039b2f830cfe5d257f95960d83680a7e4a7153118ac21e9e84a7b57f8b0996e5665c27569261822f51bb9c47 SHA512 ab72c9f501458a493458d92140286ed3ffdc1b5dc767343ce60354f6b1ded90fb8b25f914f4bbaea68fa29ef9870c2534038e44a92f84f01e1538c1f6b450b31
AUX heroes-0.21-underlink.patch 476 BLAKE2B 8e9b2892d82dd5c5b170ad1fda88766aae11955b94cf076aa6140ea781e1af314052b327b0142370b8779e5a8ed797f1148e79664f284c93c5f6921262ebda10 SHA512 6d5db649f4f1d0d7994e4fe1d6e5738276ada879ecd192be88b3dbdf900fe6991fce4fe05c52f075d0159cfab7cfd6728be322ba9f7e73556b61f43e5f9a52db
DIST heroes-0.21.tar.bz2 709079 BLAKE2B 356c7c97504c5abe6c9e94a9ba190613d199000c5f2c0dd23b8517d8e9a8b7ea81b013472af4abaf5ab2519618772e5b657281fe2dc835d3882cf788f020cad8 SHA512 fc0ac1fdf7e686388c90162b6cd76d638d295fa5919a9fdd4e944a85ca4f60b1b0a01873820b2c718ae9c960ca3d7e28ec62c09d6cd0f052e62fd2e76a96be82
DIST heroes-data-1.5.tar.bz2 391970 BLAKE2B b4325e978955ad6cfe522055755ebcc0ff487a9fdc136dbeaea30073f450d50946859d61cf44f75ab89be556e0886f8cb6ff3623c84c3275194ac81e60b1d0f9 SHA512 a4cb1508c2010b2157dc0e1d0a7973131fa167cb1f3c93649c3bc9b2c37419e4429e33cde14f3b67c7a4670f751ff4c28d88604102780bdb1fe5c77a93e1a213
DIST heroes-sound-effects-1.0.tar.bz2 389883 BLAKE2B cd4e889bf7e0b33eda33806040d3141576d60b93332d6c4bf7d41fd587bb9d661ded4f619e313e17d8508500e138f7f3ce08b9336818f85d9e240d2fdebaf4e2 SHA512 51da63373f1bdb2314a8c3164028ee9cbb95958bfe8f13b1119236f035282a711efcc6ef5a84fd647c1e8451b4da788a74e4b8506e1476a437299dfc7b2046d1
DIST heroes-sound-tracks-1.0.tar.bz2 1245613 BLAKE2B b390a96065c6b127addc0bc25326c8d0055b13f896d33e765ab9a5b3c45d831c0f91e1cff361f43a2b4956e87a6a980ce2cd07d6e6588357038f92805c64dbd1 SHA512 3e7ee2890c47366a39cfc7d7b9a1e5fdf3c3379013ca96072586ba909e2a602b114c728ffbe9dfe8eb6b62232cb6c25b13475f2a33da0243ea1ffb3f040842f0
-EBUILD heroes-0.21-r2.ebuild 1679 BLAKE2B afa68501c9ae56b4822798ab3ddf71ef174cd8097d181ad5007333922692a4501287a15405d7b90fd83772275b7151e887b504a9c73fe855674659e8f4a74f0a SHA512 c10f5113a492d26cd6f61973619e2e5b9106b603d7e76b0936ee18db8db0c1552941128a8133e72f4c9defbb9b976b2d1af763c6931a21454a7c3a378145e0de
+EBUILD heroes-0.21-r2.ebuild 1677 BLAKE2B 4ba431551a6b225f8a790a138327f30a49e093727fb344877014836439c8f3feac730de86f4060b1298d7e7e853754317448d86d2bb721d3bfa1dd1556afc19d SHA512 f7f8161a12c89993ec8ce5dc4cadb6a2ea7ce2242c6cce0a7f398730cc38b1e1e6b1758327e1bac7579b375aaf3cebccdce3387e2a67936d126a30d9f34d30eb
MISC metadata.xml 329 BLAKE2B 3d95771553c911350c23023422240c0a791ede2044a55bf40a25ac4c5ac84114ddb2942b370b9605a966d4dac960b1498f278394925d065bee642164f4893187 SHA512 f33d2b7d06f5e772abf4acb8b3dc8ba78b52ab8220a350ddc64d8bde67e850062830b4251f13021b8472b110602c937cfdc3fd34c97c37ba455542b771ecb872
diff --git a/games-action/heroes/files/heroes-0.21-compilation.patch b/games-action/heroes/files/heroes-0.21-compilation.patch
new file mode 100644
index 000000000000..e972953093c3
--- /dev/null
+++ b/games-action/heroes/files/heroes-0.21-compilation.patch
@@ -0,0 +1,48 @@
+Description: GCC 6 compilation fixes
+Author: Stephen Kitt <skitt@debian.org>
+
+Add a missing header.
+Propagate packed attributes as necessary.
+
+--- a/lib/xstrduplwr.c
++++ b/lib/xstrduplwr.c
+@@ -25,6 +25,7 @@
+
+ #include <sys/types.h>
+ #include <ctype.h>
++#include <string.h>
+
+ #include "xalloc.h"
+ #include "xstrduplwr.h"
+--- a/src/pcx.h
++++ b/src/pcx.h
+@@ -23,7 +23,7 @@
+
+ #include "video.h"
+
+-typedef struct pcx_header_type
++typedef struct ATTRIBUTE_PACKED pcx_header_type
+ {
+ a_u8 signature;
+ a_u8 version;
+@@ -39,9 +39,9 @@
+ a_u16 palette_kind;
+ a_u8 rien[58];
+ }
+-a_pcx_header ATTRIBUTE_PACKED;
++a_pcx_header;
+
+-typedef struct
++typedef struct ATTRIBUTE_PACKED
+ {
+ a_u8 r, g, b;
+ }
+@@ -54,7 +54,7 @@
+ }
+ a_palette;
+
+-typedef struct img_type
++typedef struct ATTRIBUTE_PACKED img_type
+ {
+ a_pcx_header header;
+ a_palette palette;
diff --git a/games-action/heroes/files/0.21-cvs-segfault-fix.patch b/games-action/heroes/files/heroes-0.21-cvs-segfault-fix.patch
index 689fdeea8a6c..689fdeea8a6c 100644
--- a/games-action/heroes/files/0.21-cvs-segfault-fix.patch
+++ b/games-action/heroes/files/heroes-0.21-cvs-segfault-fix.patch
diff --git a/games-action/heroes/files/heroes-0.21-gcc10.patch b/games-action/heroes/files/heroes-0.21-gcc10.patch
new file mode 100644
index 000000000000..b806e3e88784
--- /dev/null
+++ b/games-action/heroes/files/heroes-0.21-gcc10.patch
@@ -0,0 +1,16 @@
+Descriptions: Ensure variables are only declared once
+Author: Stephen Kitt <skitt@debian.org>
+
+--- a/src/persona.h
++++ b/src/persona.h
+@@ -28,8 +28,8 @@
+ * difference only if the program has a sgid or suid bit.
+ */
+
+-bool keep_sgid; /* Whether we should keep the */
+-bool keep_suid; /* SGID or SUID priviledge. */
++extern bool keep_sgid; /* Whether we should keep the */
++extern bool keep_suid; /* SGID or SUID priviledge. */
+
+ /* Get information about the current persona,
+ and switch to the user persona. */
diff --git a/games-action/heroes/heroes-0.21-r2.ebuild b/games-action/heroes/heroes-0.21-r2.ebuild
index 5ab9018ee3d1..9e7f8d9fcc0d 100644
--- a/games-action/heroes/heroes-0.21-r2.ebuild
+++ b/games-action/heroes/heroes-0.21-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils autotools
+EAPI=7
+
+inherit autotools
data_ver=1.5
snd_trk_ver=1.0
@@ -21,11 +22,17 @@ KEYWORDS="~amd64 ~x86"
IUSE="ggi nls sdl"
RESTRICT="test"
-RDEPEND="
- ggi? ( media-libs/libggi media-libs/libgii media-libs/libmikmod )
+REQUIRED_USE="^^ ( ggi sdl )"
+RDEPEND="ggi? (
+ media-libs/libggi
+ media-libs/libgii
+ media-libs/libmikmod
+ )
nls? ( virtual/libintl )
- sdl? ( media-libs/libsdl media-libs/sdl-mixer )
- !sdl? ( !ggi? ( media-libs/libsdl media-libs/sdl-mixer ) )"
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
@@ -34,7 +41,9 @@ PATCHES=(
"${FILESDIR}/${P}"-automake-1.12.patch
"${FILESDIR}/${P}"-gcc4.patch
"${FILESDIR}/${P}"-underlink.patch
- "${FILESDIR}/${PV}"-cvs-segfault-fix.patch
+ "${FILESDIR}/${P}"-cvs-segfault-fix.patch
+ "${FILESDIR}/${P}"-compilation.patch
+ "${FILESDIR}/${P}"-gcc10.patch
)
src_prepare() {
@@ -45,13 +54,13 @@ src_prepare() {
}
src_configure() {
- local myconf
-
- if use sdl || ! use ggi ; then
- myconf="${myconf} --with-sdl --with-sdl-mixer"
- else
- myconf="${myconf} --with-ggi --with-mikmod"
- fi
+ local myconf=(
+ $(use_with sdl)
+ $(use_with sdl sdl-mixer)
+ $(use_with ggi)
+ $(use_with ggi mikmod)
+ $(use_enable nls)
+ )
local pkg
for pkg in ${A//.tar.bz2} ; do
@@ -59,8 +68,7 @@ src_configure() {
econf \
--disable-heroes-debug \
--disable-optimizations \
- $(use_enable nls) \
- ${myconf}
+ "${myconf[@]}"
done
}
diff --git a/games-action/rune/Manifest b/games-action/rune/Manifest
deleted file mode 100644
index 642390427c9f..000000000000
--- a/games-action/rune/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST rune-all-0.2.tar.bz2 6507237 BLAKE2B 98afc23e076801bdf8de2fd80e5d95dfbdc74399cad91dbe2a19c3d41b1107b8b07aee5b480e212c7483e4215d9cd3c9101f8d189191aa779ed9f22f73ef9af4 SHA512 5c86306c84a6b606e13c3b1eebf676479cfe8d1112a2c5b31d6332fc7305fea74485d9a4b89286db38b968f473a40d7b5e500c17aaa8b2010edb17cc95b1695b
-EBUILD rune-1.07-r3.ebuild 3299 BLAKE2B fb8748b5eb430bd68583e1f92926216e6a24b54a8ddbd647d2cbfe6595486439785ce4d00709633aed2a7f622ac267dec1739ad5d9bfda825d1cb95ebbdeba1d SHA512 a79c44b2d8914c6b1e367a626dfd7ee9ae5061e390bda0dcec83924d6167651484810f2332eaee2667c35c2ba63c958da4e756bed5e4e4677ded221ddf67288d
-MISC metadata.xml 2118 BLAKE2B 2c390a7a3fdfe18a338dacd5d568a2912aaeacba4e75d260474a2a9c7474a9d30b0072d34b364f83ea25ae188df0a26f9f5550b25a94581a0dea1b64bd4ee055 SHA512 64d64e07f93b267b5e8682f716f2fc6cfeef77732a5c2a583d3c00bf20f5be1c257f8259c52a5c0962d5ce96bfc892b2bf1185c9219016808876164700f2ebdc
diff --git a/games-action/rune/metadata.xml b/games-action/rune/metadata.xml
deleted file mode 100644
index 51b5f12f9019..000000000000
--- a/games-action/rune/metadata.xml
+++ /dev/null
@@ -1,40 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
-</maintainer>
-<longdescription>
-Loki, god of deception and mischief was the bane of the gods, a black sheep who
-tormented all the heavens with his persistent schemes for personal power.
-Asgard, the high heaven where the gods dwelt while determining the fates of man
-and beast was often filled with the howls of pain and anguish as god after god
-fell victim to one of Loki's plots. Having one day taken these malicious schemes
-against his Asgardian brethren too far for a final time, Loki, lord of lies, was
-imprisoned by Odin the All Father and his, Thor, the god of thunder:
-
-Loki was chained to a bleak promontory hundreds of miles below the surface of
-the earth. A venomous snake of immense proportions was wound around the
-stalactites above him. From the mouth of this fearsome reptile dripped a steady
-supply of acidic venom. The torment was horrific. The steady drops would eat
-away the exiled god's midriff right down to the backbone. In turn, his immortal
-powers of healing would slowly re-issue the flesh, only to have it burned away
-again. The snake was unfailing, as were Loki's immortal healing powers.
-
-And the excruciating agony for Loki was unending.
-
-As Thor chained him to the rock, Odin All Father proclaimed that Loki would
-remain under the constant drip of the venom until the day of Ragnarok; when
-gods, men and giants would enter into a final battle and all reality as it
-existed would perish. Then, and only then, would Loki be freed from his torment.
-
-In that distant climactic battle between the gods of heaven and the monsters who
-dwelt deep in the earth, it was assumed that Loki would fulfill his fate and
-take up sides against the Asgardians. Of course, Loki was the bane of fate, and
-he had other plans.
-
-Rune was ported to Linux by Loki Entertainment Software and is a commercial
-game, requiring the original media for installation.
-</longdescription>
-</pkgmetadata>
diff --git a/games-action/rune/rune-1.07-r3.ebuild b/games-action/rune/rune-1.07-r3.ebuild
deleted file mode 100644
index 253554d25b6e..000000000000
--- a/games-action/rune/rune-1.07-r3.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils cdrom
-
-DESCRIPTION="Viking hack and slay game"
-HOMEPAGE="http://www.runegame.com"
-SRC_URI="mirror://gentoo/rune-all-0.2.tar.bz2"
-
-LICENSE="LOKI-EULA"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-RESTRICT="strip mirror bindist"
-
-RDEPEND="dev-util/xdelta:0
- >=media-libs/libsdl-1.2.9-r1[abi_x86_32(-)]
- x11-libs/libXext[abi_x86_32(-)]
- x11-libs/libX11[abi_x86_32(-)]
- virtual/opengl[abi_x86_32(-)]"
-
-S=${WORKDIR}
-
-dir=/opt/${PN}
-Ddir=${D}/${dir}
-
-src_unpack() {
- export CDROM_SET_NAMES=("Linux Rune CD" "Windows Rune CD")
- cdrom_get_cds System/rune-bin:System/Rune.exe
- dodir "${dir}"
- if [[ ${CDROM_SET} -eq 0 ]]
- then
- # unpack the data files
- tar xzf "${CDROM_ROOT}"/data.tar.gz || die
- elif [[ ${CDROM_SET} -eq 1 ]]
- then
- # unpack the runelinuxfiles.tar.gz
- unpack ${A}
- fi
-}
-
-src_install() {
- insinto "${dir}"
- exeinto "${dir}"
- einfo "Copying files... this may take a while..."
-
- case ${CDROM_SET} in
- 0)
- for x in Help Maps Meshes Sounds System Textures Web
- do
- doins -r $x
- done
-
- # copy linux specific files
- doins -r "${CDROM_ROOT}"/System
-
- # the most important things: rune and ucc :)
- doexe "${CDROM_ROOT}"/bin/x86/rune
- fperms 750 "${dir}"/System/{ucc{,-bin},rune-bin}
-
- # installing documentation/icon
- dodoc "${CDROM_ROOT}"/{README,CREDITS}
- newicon "${CDROM_ROOT}"/icon.xpm rune.xpm
- ;;
- 1)
- # copying Maps Sounds and Web
- for x in Maps Sounds Web
- do
- doins -r "${CDROM_ROOT}"/$x
- done
-
- # copying the texture files
- dodir "${dir}"/Textures
- for x in $(find "${CDROM_ROOT}"/Textures/ -type f -printf '%f ')
- do
- echo -ne '\271\325\036\214' | cat - "${CDROM_ROOT}"/Textures/$x \
- | sed -e '1 s/\(....\)..../\1/' > "${Ddir}"/Textures/$x \
- || die
- done
-
- doins -r "${S}"/System
- doins -r "${S}"/Help
- sed -e "s:.*\(\w+/\w+\)\w:\1:"
- for x in $(ls "${S}"/patch/{System,Maps,Meshes} | sed -e \
- "s:.*/\([^/]\+/[^/]\+\).patch$:\1:")
- do
- xdelta patch "${S}"/patch/${x}.patch "${CDROM_ROOT}"/${x} "${S}"/patch/${x}
- doins "${S}"/patch/${x}
- done
-
- insinto "${dir}"/System
-
- # copying system files from the Windows CD
- for x in "${CDROM_ROOT}"/System/*.{int,u,url}; do
- doins $x
- done
-
- # modify the files
- mv "${Ddir}"/System/OpenGlDrv.int "${Ddir}"/System/OpenGLDrv.int \
- || die
- mv "${Ddir}"/Textures/bloodFX.utx "${Ddir}"/Textures/BloodFX.utx \
- || die
- mv "${Ddir}"/Textures/RUNESTONES.UTX "${Ddir}"/Textures/RUNESTONES.utx \
- || die
- mv "${Ddir}"/Textures/tedd.utx "${Ddir}"/Textures/Tedd.utx \
- || die
- mv "${Ddir}"/Textures/UNDERANCIENT.utx "${Ddir}"/Textures/UnderAncient.utx \
- || die
- rm "${Ddir}"/System/{Setup.int,SGLDrv.int,MeTaLDrv.int,Manifest.int,D3DDrv.int,Galaxy.int,SoftDrv.int,WinDrv.int,Window.int} \
- || die
-
- # the most important things: rune and ucc :)
- doexe "${S}"/bin/x86/rune
- fperms 750 "${dir}"/System/{ucc,ucc-bin,rune-bin}
-
- # installing documentation/icon
- dodoc "${S}"/{README,CREDITS}
- doicon "${S}"/rune.xpm rune.xpm
- ;;
- esac
-
- use amd64 && mv "${Ddir}"/System/libSDL-1.2.so.0 \
- "${Ddir}"/System/libSDL-1.2.so.0.backup
-
- make_wrapper rune ./rune "${dir}" "${dir}"
- make_desktop_entry rune "Rune" rune
- find "${Ddir}" -exec touch '{}' \; || die
-}