summaryrefslogtreecommitdiff
path: root/games-action
diff options
context:
space:
mode:
Diffstat (limited to 'games-action')
-rw-r--r--games-action/Manifest.gzbin13676 -> 13840 bytes
-rw-r--r--games-action/multimc-bin/Manifest3
-rw-r--r--games-action/multimc-bin/metadata.xml28
-rw-r--r--games-action/multimc-bin/multimc-bin-1.5.1.ebuild48
-rw-r--r--games-action/nighthawk/Manifest4
-rw-r--r--games-action/nighthawk/files/nighthawk-2.2-gcc42.patch24
-rw-r--r--games-action/nighthawk/files/nighthawk.patch46
-rw-r--r--games-action/nighthawk/nighthawk-2.2-r1.ebuild28
-rw-r--r--games-action/snipes/Manifest2
-rw-r--r--games-action/snipes/snipes-1.0.4-r1.ebuild13
-rw-r--r--games-action/xblast/Manifest2
-rw-r--r--games-action/xblast/xblast-2.10.4-r1.ebuild74
-rw-r--r--games-action/xblast/xblast-2.10.4-r2.ebuild65
13 files changed, 151 insertions, 186 deletions
diff --git a/games-action/Manifest.gz b/games-action/Manifest.gz
index 683e35fd7865..4016585d5902 100644
--- a/games-action/Manifest.gz
+++ b/games-action/Manifest.gz
Binary files differ
diff --git a/games-action/multimc-bin/Manifest b/games-action/multimc-bin/Manifest
new file mode 100644
index 000000000000..2857e995da0b
--- /dev/null
+++ b/games-action/multimc-bin/Manifest
@@ -0,0 +1,3 @@
+DIST multimc_1.5-1.deb 7692 BLAKE2B c5b4de864c95cccd96b071d4d551e322eb5c78e17a8da361ee69a82405691c6d9fc81c7eef9dcf855a8e2145fbb362d31c7f63682c7a66edbc37dbf9215e7c1b SHA512 26fe11eff406efd09612002e4c53fc1ea0b3f7d0aca389475a7afff454efa52ed52097f6a0bbc27de61fba3fed252321754738a0f79b0d8a7308a39701087e67
+EBUILD multimc-bin-1.5.1.ebuild 1407 BLAKE2B c7524f67d2cf2005ad4626efa2d69ad078aedd65c9b2888c05d1e1d01ce758bf4b85a239d1efe923341126e217f64b461274a8253096d92fae8aa5cd3b0a648a SHA512 81d5cb1dc9b09aeea7017a4327391245dfff3e9eae8a4d805aeaa0e40994916cfc566e784ee27c455e31fd50e768b1b4ec2d0c77fadc63dbc4db4863678a0808
+MISC metadata.xml 1352 BLAKE2B 61d0cb2977513e27455c82f355c3e3138594c6c52da901cb6543ae78e2189007ab5188e72f1477950ac7844bd0e5201a98b37a1f088ca4e3b9a32abb074b4540 SHA512 1c63a1947008aea378f548443cd8af55dc7bc1cf9d4179aa01a8c815b5fb778eb2ca5e09e912473f0a1335d58add88a1e819207eb8461438b1da5a0ce45760f6
diff --git a/games-action/multimc-bin/metadata.xml b/games-action/multimc-bin/metadata.xml
new file mode 100644
index 000000000000..9246e9cd3415
--- /dev/null
+++ b/games-action/multimc-bin/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">MultiMC/MultiMC5</remote-id>
+ <bugs-to>https://github.com/MultiMC/MultiMC5/issues</bugs-to>
+ </upstream>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <longdescription>
+ MultiMC is a custom launcher for Minecraft that allows you to easily manage multiple installations of Minecraft at once. It also allows you to easily install and remove mods by simply dragging and dropping. Here are the current features of MultiMC:
+
+ - Manage multiple instances of Minecraft at once
+ - Start Minecraft with a custom resolution
+ - Change Java's runtime options (including memory options)
+ - Shows Minecraft's console output in a colour-coded window
+ - Kill Minecraft easily if it crashes/freezes
+ - Custom icons and groups for instances
+ - Forge, Fabric and LiteLoader integration (automatic installation, version downloads, mod management)
+ - Import of Curse modpacks
+ - LWJGL version changing built-in
+ - Supports every version of Minecraft that the vanilla launcher does
+ - Upload screenshots
+ - Import, export Instances allowing you to share with friends and/or make backups
+ </longdescription>
+</pkgmetadata>
diff --git a/games-action/multimc-bin/multimc-bin-1.5.1.ebuild b/games-action/multimc-bin/multimc-bin-1.5.1.ebuild
new file mode 100644
index 000000000000..2e4e4a210532
--- /dev/null
+++ b/games-action/multimc-bin/multimc-bin-1.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker xdg
+
+DESCRIPTION="An advanced Qt5-based open-source launcher for Minecraft"
+HOMEPAGE="https://multimc.org https://github.com/MultiMC/MultiMC5"
+SRC_URI="https://files.multimc.org/downloads/multimc_$(ver_rs 2 -).deb"
+# We need -bin because of secret API keys:
+# https://github.com/MultiMC/MultiMC5/issues/4087
+# https://github.com/MultiMC/MultiMC5/issues/4113
+# https://bugs.gentoo.org/814404
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+LICENSE="Apache-2.0 Boost-1.0 BSD-2 BSD GPL-2+ LGPL-2.1-with-linking-exception LGPL-3 OFL-1.1 MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtgui:5
+ dev-qt/qttest:5
+ dev-qt/qtxml:5
+ sys-libs/zlib
+ >=virtual/jre-1.8.0
+ virtual/opengl
+ x11-libs/libXrandr
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ mv "${S}"/* "${ED}" || die
+ # Rename the .desktop file to avoid file conflict with non-bin version
+ mv "${ED}/usr/share/applications/multimc.desktop" "${ED}/usr/share/applications/multimc-bin.desktop" || die
+ # Change the name so we can differentiate from the non-bin version in app menu
+ # and remove empty options
+ sed -i \
+ -e 's/Name=MultiMC 5/Name=MultiMC Official Binary/g' \
+ -e '/Path=/d' \
+ -e '/TerminalOptions=/d' \
+ "${ED}/usr/share/applications/multimc-bin.desktop" || die
+}
diff --git a/games-action/nighthawk/Manifest b/games-action/nighthawk/Manifest
index 00c0a2e1c86b..2c8289e485ba 100644
--- a/games-action/nighthawk/Manifest
+++ b/games-action/nighthawk/Manifest
@@ -1,8 +1,4 @@
-AUX nighthawk-2.2-gcc42.patch 670 BLAKE2B a5d0b38983e0ed434f13225f213bc64142629b4d7189fb1665271c45129f1a4e3086210911310c7cd09362328030f2242179e4e1c3e07b87cf21475ecdddee9b SHA512 f23188baa922881b36c45900e34bcaaa04b9c9752c52c13d5c03454e46853aae6c5f50375e87785b4d9866a0156b697b9dbfac0eb4f54aaa92fec5c5185686b1
AUX nighthawk-4.0-cmake.patch 938 BLAKE2B 8392d2368a709f51687fa007118e7b7e34c80fa3fbfc7e122ee65b6b680c5320d0860e369b48ad4b94e2621c780bd6d41bce86fd72fe30c7459087703279f2dc SHA512 9e02369e1e218e44544cfe5bfbe5f6ceceed62098e09c1fd4ffaca09cdd87d644a2957045447206926e0a6d0250163b4c16513618a0964534c995ed093dd58ea
-AUX nighthawk.patch 1235 BLAKE2B 644abc5e0910550f6dfd103ba02aee064ee4c63b2161fa3443ec5abf5da64350e43ab79b2d6cff65a00ca963c96bf456eb374bdc874cec45df9e0180dd697cb0 SHA512 6362d1188c857f5b1236b5ca9e04e00d8eb85eb1a7e2efaa588c1b8cdcfd11f61a914e0db8f5bffd377c495b1464e7060c79d9205abbe84bfa24112c4be4e237
-DIST nighthawk-2.2-1.tar.gz 1079706 BLAKE2B 38b9e2fe6f9fe4b373ddae05f0277eea1dd65f921f99e0f728ca47630378ad865117846945ba5c708cef7120dbda8c5c1ac5a032738d974f2687be34fe561556 SHA512 dca5d0c01ed651dee0c29b939c832ae343ca70ff0eb7779e7c13007881cf75d96cadafbbac6b431cd473ce9b9e1347dd4ba90502627059439b5a9a557cbc3fcf
DIST nighthawk-4.0.tar.xz 3212124 BLAKE2B ccd8d97ac03e6d984bdb56cad49ceabb7e6f61dd182d359e1410ff081e3fc456d2a844bc513238d6b10ba8c479661fb890a6c1e41815b7ac6f8f7f761209feb2 SHA512 f1d10026df3a2ab274b81c4e8f28c79c2ba21d6ccab59b217308b076fc7ed3ef4fa5f2b895b72902f72a652c950faa15e43f2e7c91bfc0e2c988ef1aee6859a6
-EBUILD nighthawk-2.2-r1.ebuild 614 BLAKE2B 21ed1d82be90a6b378521f25b9441936c683bb72a6e893ad9e97a61b2ee0a0516e39064e588c03660c22c7dc82448dc41127e826b9111271a82ecf2339ef9eef SHA512 f83933b6464b23625ec8395a1b2c2fc45b2229addc2a88c8fe8c9630e45b4ec85ef0cd59a0bc242e2966158e091e4a9e7ca8fc17505d2a8ed8eab3694b3245ec
EBUILD nighthawk-4.0.ebuild 1077 BLAKE2B dc15f8f6dcdd73fa36e492bd7f878e8cb681dcd12cd411b41943adf2c6da710614bce191dc0169b34ec91edb68a24153a342c0decd436b12912cd9df1c133031 SHA512 a95bcecd3243d083f714b714164fcea9dcb70e3f7baf4b773d4b45754d79903dd36b4bcec4648b02fd506abe3be6fa96f6b2b54a21162edb662de57b86052fe0
MISC metadata.xml 334 BLAKE2B 1bc8093b8dce38b89654d081249100a78ad90bfdaf422fe56ec693f1d3678fbcbe2db40ca18f2dfcb35f79c4bad2f5c2672a5094586615e6326b1961bb057049 SHA512 582f9e65780f1c6f77c0714543bc17cfd49f9d0154487a99da137177812455a457c524fb3744e5b876156c98b1ed65b264ed675e51eb0cf921b9f1d077e8b49e
diff --git a/games-action/nighthawk/files/nighthawk-2.2-gcc42.patch b/games-action/nighthawk/files/nighthawk-2.2-gcc42.patch
deleted file mode 100644
index a9ad8c98484a..000000000000
--- a/games-action/nighthawk/files/nighthawk-2.2-gcc42.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/src_sound/dsp_mixxer.c
-+++ b/src_sound/dsp_mixxer.c
-@@ -302,10 +302,8 @@
- for(sample_no = 0;sample_no < mix_buffer_size;sample_no++)
- {
- if(chmix[chan_no].funkctrl & 0x2)
--#pragma pack(1)
- sam = *((sDB *)chmix[chan_no].sample_addr +
- (unsigned long)chmix[chan_no].sample_ptr);
--#pragma pack()
- else
- sam = 0;
-
-@@ -364,10 +362,8 @@
- for(sample_no = 0;sample_no < mix_buffer_size;sample_no++)
- {
- if(chmix[chan_no].funkctrl & 0x2)
--#pragma pack(1)
- sam = *((sDW *)chmix[chan_no].sample_addr +
- (unsigned long)chmix[chan_no].sample_ptr);
--#pragma pack()
- else
- sam = 0;
- #ifdef DIGITAL_ECHOING
diff --git a/games-action/nighthawk/files/nighthawk.patch b/games-action/nighthawk/files/nighthawk.patch
deleted file mode 100644
index accef759e682..000000000000
--- a/games-action/nighthawk/files/nighthawk.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff -c -3 -r nighthawk-2.2/src/nighthawk.cc nighthawk.orig/src/nighthawk.cc
-*** nighthawk-2.2/src/nighthawk.cc Sun May 23 01:10:59 1999
---- nighthawk.orig/src/nighthawk.cc Fri Jul 12 04:18:38 2002
-***************
-*** 20,25 ****
---- 20,26 ----
- #include <string.h>
- #include <signal.h>
- #include <pwd.h>
-+ #include <time.h>
- #include <sys/types.h>
- #include <sys/file.h>
- #include <sys/stat.h>
-diff -c -3 -r nighthawk-2.2/src_sound/Make.common nighthawk.orig/src_sound/Make.common
-*** nighthawk-2.2/src_sound/Make.common Sat May 1 18:04:08 1999
---- nighthawk.orig/src_sound/Make.common Fri Jul 12 04:23:51 2002
-***************
-*** 10,16 ****
- endif
- endif
-
-! HOST_SAFE = 0
-
- ifeq ($(HOSTTYPE),i386)
- HOST_SAFE = 1
---- 10,16 ----
- endif
- endif
-
-! HOST_SAFE = 1
-
- ifeq ($(HOSTTYPE),i386)
- HOST_SAFE = 1
-*** nighthawk-2.2/src/object.cc Mon Sep 30 21:54:56 2002
---- nighthawk-orig/src/object.cc Mon Sep 30 21:55:05 2002
-***************
-*** 32,37 ****
---- 32,39 ----
- #include "tdroid_8xx.h"
- #include "tdroid_9xx.h"
-
-+ #include <string.h>
-+
- /***************************************************************************
- *
- ***************************************************************************/
diff --git a/games-action/nighthawk/nighthawk-2.2-r1.ebuild b/games-action/nighthawk/nighthawk-2.2-r1.ebuild
deleted file mode 100644
index bba6757c9e18..000000000000
--- a/games-action/nighthawk/nighthawk-2.2-r1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="A tribute to Paradroid by Andrew Braybrook"
-HOMEPAGE="http://night-hawk.sourceforge.net/nighthawk.html"
-SRC_URI="ftp://metalab.unc.edu/pub/Linux/games/arcade/${P}-1.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="x11-libs/libXpm"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/nighthawk.patch
- "${FILESDIR}"/${P}-gcc42.patch
-)
-
-src_prepare() {
- default
-
- sed -i -e 's:AC_FD_MSG:6:g' configure || die #218936
- sed -i -e '/LDFLAGS = /d' src/Makefile.in || die
-}
diff --git a/games-action/snipes/Manifest b/games-action/snipes/Manifest
index ef37e8ef15dd..208bc76ae32e 100644
--- a/games-action/snipes/Manifest
+++ b/games-action/snipes/Manifest
@@ -1,4 +1,4 @@
AUX snipes-1.0.4-ldflags.patch 350 BLAKE2B 30f5249402d716ae2252aa3007ca2f860a486c7096486fa2fe5a5cf0c779b4f608eda20f033065ed71980d88035c4aede943c093881cc97d31f26fecccdfd0a8 SHA512 d1c90ab8e8ac89a3b335c89d05d3ce9cc4bb2e805290e5ad4d5ee6b96790ad91f5cd40d9ef56cfe5d31eff76fb62e35c175eba7f15877a98a8eb6ad17ac772d0
DIST snipes-1.0.4.tar.gz 39150 BLAKE2B 00bf82f65720a86a7eb32ce50edd92db434dd8cbcfd76caad102bf5bd5087141f0b97d41260d7c0fc2709a7506470d53c08672c2b2c6733fcb3ee718b5875755 SHA512 de2cfdc3062055bfd04766f11894786af2ccd57ee1c8bcfe28d2d6894fe543830061ad7d16fa5e0363a25dcfd4a4c297ec0b81e449392a7b2b7d65da2e2a2f9b
-EBUILD snipes-1.0.4-r1.ebuild 836 BLAKE2B ebe4712222190d20fe97f8fa6dbe5deefd1c479f3c72c0b039875dab84f4cd777834e101d1cfd6b89170089fc8cdbefc2f24675b66e911656e1ee796f4abd4a8 SHA512 4ca18c6815cede5bab983f21af0250e8fc0280e93df1b94ed2d0bcbeb23defac121212f526a926752ea2e491e0949bec07c8083b2807f12fbfd0b9c95d7459be
+EBUILD snipes-1.0.4-r1.ebuild 777 BLAKE2B 5d5b2a01255a250c3e3282ca83af444dcc4d2ffc12908a3f43706b84b3662bb07809f8fd8c503743c27a4e04893cb154c0d474d24740965803ffa273319c076d SHA512 0c76e82a0243dbe61e9a74c33b62ab9303e1a0631ea17fb6bd63ec38ee237aad97a6cf632be6693dc72818450a6640a566d7e774413304ed695e0e526850b9e4
MISC metadata.xml 250 BLAKE2B 8d44bd4c6e7d6491273e2015e36ddac74af7b94a124fd240ff030e16430f5c85e53ab812f0e3e94bb2e6d138f39b512bbe01ff98b0081cacc21a02d648ec7643 SHA512 80ac07a3cac10ad2e72e9989a130b7d2073934fe92914a9db2af4d0e769d4bf537770f8faba0654bbd64a7e85ee38cf1f9d03b4b9cd322864b1b2bb35087d610
diff --git a/games-action/snipes/snipes-1.0.4-r1.ebuild b/games-action/snipes/snipes-1.0.4-r1.ebuild
index 6b6beac3a3a4..5a2429cee6aa 100644
--- a/games-action/snipes/snipes-1.0.4-r1.ebuild
+++ b/games-action/snipes/snipes-1.0.4-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit desktop flag-o-matic toolchain-funcs
+inherit desktop flag-o-matic multilib toolchain-funcs
DESCRIPTION="2D scrolling shooter, resembles the old DOS game of same name"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
@@ -23,16 +23,13 @@ PATCHES=(
src_compile() {
tc-export CC LD
- # lld requires arch flags to be passed even if native (bug #730852)
- local archflags=
- tc-ld-is-lld && eval archflags=\${LDFLAGS_${ARCH}}
-
- LDLIBS=-lm emake RAW_LDFLAGS="${archflags} $(raw-ldflags)"
+ # lld requires abi flags to be passed even if native (bug #730852)
+ LDLIBS=-lm emake RAW_LDFLAGS="$(get_abi_LDFLAGS) $(raw-ldflags)"
}
src_install() {
- dobin snipes
- doman snipes.6
+ dobin ${PN}
+ doman ${PN}.6
einstalldocs
doicon ${PN}.png
diff --git a/games-action/xblast/Manifest b/games-action/xblast/Manifest
index adc11d260e9c..58c783a8fcd1 100644
--- a/games-action/xblast/Manifest
+++ b/games-action/xblast/Manifest
@@ -5,5 +5,5 @@ DIST models-2005-01-06.tar.gz 1738564 BLAKE2B 7dfd87e47bf4555d6f01c59e83d1a34151
DIST musics-2005-01-06.tar.gz 5317575 BLAKE2B 583d33535c5e80f691e9be7545038ca5dee602a1522f7749ffde0cbd9691378c9bb06c783548482eb26a61f74e3ad3cfac9166382d0644bd450eca1af0f08ed3 SHA512 885591cf5f32d76bc5bae150b24592c8eccd6f33afa5d40570429371b328671c3902c565446dae24bf949ac67b681e39e46e8d4ea737f52c66d467c09a210ede
DIST sounds.tar.gz 1612625 BLAKE2B eb1ce96370dfafd254ef50334bd6e296045da6825773704d95f5778e854da4c1460fc0a24ae6c3e0c2c3784723fbce4198dfd7331ca9c18ab0324fef6ef6f3f1 SHA512 69518766ce1cc1bef543964acb077de51c361f1a880ebc11bd0d381fe082af0e013d116aad606a18c94855a08c5a2892cb5d0d5a259b081119bb8d355a94e2b2
DIST xblast-2.10.4.tar.gz 684965 BLAKE2B e9709f539705b9e14831fa036c540877d0d55ce8c975048c8eac0abbf2e391e36b37e4c119118d73f5bf5e888f3fbef4c1dba361b3ba1874909644f948c57613 SHA512 6b3be0d41d18cf8da721030fa87c00ffed81d29706a20dd254a07b9cc8af79bd09f63ebb7f575c1665b77b9f58f29bec74b84f27fd2106d704c2fe2d5513a835
-EBUILD xblast-2.10.4-r1.ebuild 1545 BLAKE2B 3c288f4707e28258e62a195cb00c25e3168b908342b0aacf533a6049fec74bad9624265ef0527b9154c37db794d66b07b5279dd61eb359f40e22c392f26794c1 SHA512 ef688c58dd792d99702dfd1a38f09c861345ceb91aa84017362b7860a60572512fee775c8c7abdb5438d831365286d7d560a6fd03eb7e58ff5db8f4f7144d20b
+EBUILD xblast-2.10.4-r2.ebuild 1294 BLAKE2B 45c209a4cdc2bda6b061e70f263812b0ce005bee8d3a276b5a3952493d83cbcb4f172dc14a513399b7a042e5dc222fa5b82217e8f4a799e51204e67a11306c69 SHA512 48cbd0b6ca984104bbd501e9f9f79bd2b779e247797cc8499c58c329cedc840e73fefbba0cd787f9da3343da0d44cc53177e79fd175de8f0949bec7ee650f9ed
MISC metadata.xml 330 BLAKE2B f862187afb374059b562c698dc13ea871667c07958b620cf6edf3e9326552d7b7f63742c0279177e379f0b7e6253960c6fb987fc726a16e8fc355466b58e9bcb SHA512 514cabf43b313eb86826c0f2feafde111267b7fe0a6004d82b2a32d16641a3f406ace96b677c1d911e61f1ea83fc95f06e594aea1aa0f2f02d9d928b40777f12
diff --git a/games-action/xblast/xblast-2.10.4-r1.ebuild b/games-action/xblast/xblast-2.10.4-r1.ebuild
deleted file mode 100644
index 3da27dd600ac..000000000000
--- a/games-action/xblast/xblast-2.10.4-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools
-
-# Change these as releases changes
-IMAGES="images-2005-01-06"
-LEVELS="levels-2005-01-06"
-MODELS="models-2005-01-06"
-MUSICS="musics-2005-01-06"
-SOUNDS="sounds"
-
-DESCRIPTION="Bomberman clone w/network support for up to 6 players"
-HOMEPAGE="http://xblast.sourceforge.net/"
-SRC_URI="mirror://sourceforge/xblast/${P}.tar.gz
- mirror://sourceforge/xblast/${IMAGES}.tar.gz
- mirror://sourceforge/xblast/${LEVELS}.tar.gz
- mirror://sourceforge/xblast/${MODELS}.tar.gz
- mirror://sourceforge/xblast/${MUSICS}.tar.gz
- mirror://sourceforge/xblast/${SOUNDS}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- media-libs/libpng:0
- x11-libs/libICE
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- x11-libs/libXt"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc-10.patch
-)
-
-src_prepare() {
- default
-
- eautoreconf #255857
-}
-
-src_configure() {
- econf \
- --with-otherdatadir=/usr/share/${PN} \
- --enable-sound
-}
-
-src_install() {
- local IMAGE_INSTALL_DIR="/usr/share/${PN}/image"
-
- default
-
- # Images
- dodir "${IMAGE_INSTALL_DIR}"
- cp -pPR "${WORKDIR}/${IMAGES}"/* "${D}/${IMAGE_INSTALL_DIR}" || die
-
- # Levels
- insinto "/usr/share/${PN}/level"
- doins "${WORKDIR}/${LEVELS}"/*
-
- # Models
- insinto "/usr/share/${PN}/image/sprite"
- doins "${WORKDIR}/${MODELS}"/*
-
- # Music and sound
- insinto "/usr/share/${PN}/sounds"
- doins "${WORKDIR}/${MUSICS}"/* "${WORKDIR}/${SOUNDS}"/*
-
- # Cleanup
- find "${D}" -name Imakefile -exec rm \{\} \;
-}
diff --git a/games-action/xblast/xblast-2.10.4-r2.ebuild b/games-action/xblast/xblast-2.10.4-r2.ebuild
new file mode 100644
index 000000000000..0f7e212495eb
--- /dev/null
+++ b/games-action/xblast/xblast-2.10.4-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop
+
+MY_GAMEDATA=(
+ images-2005-01-06:image
+ levels-2005-01-06:level
+ models-2005-01-06:image/sprite
+ musics-2005-01-06:sounds
+ sounds
+)
+
+DESCRIPTION="Bomberman clone with network support for up to 6 players"
+HOMEPAGE="http://xblast.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/xblast/${P}.tar.gz
+ $(printf 'mirror://sourceforge/xblast/%s.tar.gz ' "${MY_GAMEDATA[@]%:*}")"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ media-fonts/font-adobe-100dpi"
+DEPEND="
+ x11-base/xorg-proto
+ x11-libs/libX11
+ x11-libs/libXt"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-10.patch
+)
+
+src_prepare() {
+ default
+
+ find "${WORKDIR}" -name Imakefile -exec rm {} + || die
+
+ # badly non-utf8 named file that doesn't match xblast.wxs runtime #750077
+ mv "${WORKDIR}"/levels-2005-01-06/reconstruct{?,i}on2.xal || die
+
+ eautoreconf #255857
+}
+
+src_configure() {
+ econf \
+ --enable-sound \
+ --with-otherdatadir="${EPREFIX}"/usr/share/${PN}
+}
+
+src_install() {
+ default
+
+ local data
+ for data in "${MY_GAMEDATA[@]}"; do
+ insinto /usr/share/${PN}/${data#*:}
+ doins -r "${WORKDIR}"/${data%:*}/.
+ done
+
+ make_desktop_entry ${PN} XBlast applications-games
+}