summaryrefslogtreecommitdiff
path: root/games-action/xpilot
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/xpilot')
-rw-r--r--games-action/xpilot/Manifest3
-rw-r--r--games-action/xpilot/xpilot-4.5.5-r1.ebuild43
2 files changed, 28 insertions, 18 deletions
diff --git a/games-action/xpilot/Manifest b/games-action/xpilot/Manifest
index 2e4c9edc6f01..35f07b9e6a4e 100644
--- a/games-action/xpilot/Manifest
+++ b/games-action/xpilot/Manifest
@@ -1,3 +1,4 @@
DIST xpilot-4.5.5.tar.bz2 1115502 BLAKE2B 9f7758dabc834f9ffad602e2ba215e1e08ff3f33b21480eae0176775d6c55df3e3238652e0cbbbc688acbab9e23395f46d853ee52fd55d177fdace5138621335 SHA512 002fbdbee3035e21f441d749d68ac41da2816a691e1c0d1cf9de9cddaa479c92da57eb36081884b9908a6ae83454f6f532c24c89280d27e2cbf9570442ef301c
-EBUILD xpilot-4.5.5-r1.ebuild 1323 BLAKE2B 5cbf85537a282375ff1cfa29f521854f63808faba63fb192dcca21030c35d1a91bb478a8e6c0e84f486109afe8ce00dcd5395d46da04d158d6188c87191f3fcb SHA512 2dc6dff33936b8408a7c19ec9511fcc96bbdbc5acd8f22e76f61e1b10818c057c817c2bd74d88978fa5749dc921e3f13bec2f8108b982fb005c689d958a54f0c
+DIST xpilot.png 9682 BLAKE2B 689ac9d6efe54ee1d8c166543cd7c720ebd71c05818b074dffdcb1499d645c3cb9f9db00ce8c6f29d433255d0f58e2d30897f1438c0b41e13f5fd2043e5bac46 SHA512 5a59f01399b03852a795f5c475ce64cf2890e102b806c5e3540c635ad32d1a16f6a0e2c4dd8d0de0a33a9fbc907b68640f151905b71a54556b59a83602036f95
+EBUILD xpilot-4.5.5-r1.ebuild 1385 BLAKE2B fda63805eef5cfc09619d695732dd124cbfd512305232e86db7b1fead23a6098cec2a49e5ee348a1bab8d7ecc3b8f1ed16c3914cbe8a6a534e87641fff58330a SHA512 a7b70db444ea7004d89ccd0306db1706ecde1b3c21e3b86996a1e1b9996b9c73cb5340ea19dfa748d8fc70edbc160d904fd454fce6d7a80324b3938d6b058226
MISC metadata.xml 333 BLAKE2B 2c8f9dc52fcf4780ad3da4ee828dad3ef62731f0d2f399da8ade242756b6929a58a6b60347ed753f19dbbf6cf2146dadeb88fa20be6d035ae3fc41ca581bacdb SHA512 b6a52a4afe7804b04646d42366ef3812a70fba44d44e9da662a70c7c646aba015792fd8bef65da9c5abdc4b5188cf0657ba80ab1d1920b6b692606274c3afca4
diff --git a/games-action/xpilot/xpilot-4.5.5-r1.ebuild b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
index c90d59c476c1..28e96af330c1 100644
--- a/games-action/xpilot/xpilot-4.5.5-r1.ebuild
+++ b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
@@ -1,35 +1,44 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit desktop toolchain-funcs
-DESCRIPTION="A multi-player 2D client/server space game"
+DESCRIPTION="Multi-player 2D client/server space game"
HOMEPAGE="http://www.xpilot.org/"
-SRC_URI="mirror://sourceforge/xpilotgame/${P}.tar.bz2"
+SRC_URI="
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png
+ mirror://sourceforge/xpilotgame/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXext"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
app-text/rman
- x11-base/xorg-proto
x11-misc/gccmakedep
>=x11-misc/imake-1.0.8-r1"
+DOCS=(
+ README.txt
+ doc/{ChangeLog,CREDITS,FAQ,TODO}
+ doc/README.{MAPS,MAPS2,SHIPS,sounds,talkmacros}
+)
+
src_prepare() {
- #default
- eapply_user
+ default
sed -i \
- -e '/^INSTMAN/s:=.*:=/usr/share/man/man6:' \
- -e "/^INSTLIB/s:=.*:=/usr/share/${PN}:" \
- -e "/^INSTBIN/s:=.*:=/usr/bin:" \
+ -e "/^INSTMAN/s|=.*|=${EPREFIX}/usr/share/man/man6|" \
+ -e "/^INSTLIB/s|=.*|=${EPREFIX}/usr/share/${PN}|" \
+ -e "/^INSTBIN/s|=.*|=${EPREFIX}/usr/bin|" \
Local.config || die
# work with glibc-2.20
@@ -53,9 +62,9 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install
+ default
emake DESTDIR="${D}" install.man
- newicon lib/textures/logo.ppm ${PN}.ppm
- make_desktop_entry ${PN} XPilot /usr/share/pixmaps/${PN}.ppm
- dodoc README.txt doc/{ChangeLog,CREDITS,FAQ,README*,TODO}
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} XPilot
}