summaryrefslogtreecommitdiff
path: root/games-action/xpilot/xpilot-4.5.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/xpilot/xpilot-4.5.5-r1.ebuild')
-rw-r--r--games-action/xpilot/xpilot-4.5.5-r1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/games-action/xpilot/xpilot-4.5.5-r1.ebuild b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
index e76581df3051..9ecd8ae3d47c 100644
--- a/games-action/xpilot/xpilot-4.5.5-r1.ebuild
+++ b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit desktop toolchain-funcs
+inherit desktop flag-o-matic toolchain-funcs
DESCRIPTION="Multi-player 2D client/server space game"
HOMEPAGE="http://www.xpilot.org/"
@@ -49,6 +49,8 @@ src_prepare() {
}
src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf -a || die
}