summaryrefslogtreecommitdiff
path: root/games-action/fakk2
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/fakk2')
-rw-r--r--games-action/fakk2/Manifest2
-rw-r--r--games-action/fakk2/fakk2-1.02-r1.ebuild64
-rw-r--r--games-action/fakk2/metadata.xml11
3 files changed, 77 insertions, 0 deletions
diff --git a/games-action/fakk2/Manifest b/games-action/fakk2/Manifest
new file mode 100644
index 000000000000..e626e8c64035
--- /dev/null
+++ b/games-action/fakk2/Manifest
@@ -0,0 +1,2 @@
+EBUILD fakk2-1.02-r1.ebuild 1662 BLAKE2B a5f89834da712fbc95fbce9934a08b51c806937042e0d8df372427e6a24293455c7335bc1b3f354ce0140630b5ce2086904032c718a60c924e699137755727ea SHA512 60f1588dec82c4bfce2c02ed0ee8668d32aeaacee540084611f2b85aec46c1964cfb3d73e604b6bc7ee2187ddd6c3ec5a8cc0b4ed1921aee42f14181f9a336c8
+MISC metadata.xml 1206 BLAKE2B a3c0be20590459e2401b791c4c1211f7155d4e76f34757ad180c9626729f431ee77a00a30b25076cef69705e64cd54ca581d147132f2c8323b9053013255d5a8 SHA512 786927f7a429e4ff1f1097144f41b832b7d8bd8fd1423dd5587d3c496a2ed4be66aa34702e360c702f536429ceed38082475529392c5e0ef389aa431d2595432
diff --git a/games-action/fakk2/fakk2-1.02-r1.ebuild b/games-action/fakk2/fakk2-1.02-r1.ebuild
new file mode 100644
index 000000000000..b038c25d14ee
--- /dev/null
+++ b/games-action/fakk2/fakk2-1.02-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils cdrom
+
+DESCRIPTION="3D third-person action shooter based on the Heavy Metal comics/movies"
+HOMEPAGE="http://www.lokigames.com/products/fakk2/"
+SRC_URI=""
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nocd"
+RESTRICT="strip"
+
+RDEPEND="virtual/opengl"
+
+S=${WORKDIR}
+
+dir=/opt/${PN}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ if use nocd ; then
+ ewarn "The installed game takes about 378MB of space!"
+ fi
+}
+
+src_install() {
+ cdrom_get_cds fakk
+ einfo "Copying files... this may take a while..."
+ exeinto "${dir}"
+ doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/${PN}
+ insinto "${dir}"
+ doins ${CDROM_ROOT}/{README,icon.{bmp,xpm}}
+ exeinto "${dir}"/fakk
+ doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/fakk/{c,f}game.so
+ if use nocd ; then
+ insinto "${dir}"/fakk
+ doins ${CDROM_ROOT}/fakk/pak{0,1,2,3}.pk3
+ doins ${CDROM_ROOT}/fakk/default.cfg
+ fi
+
+ # Now, since these files are coming off a cd, the times/sizes/md5sums won't
+ # be different ... that means portage will try to unmerge some files (!)
+ # So, we run touch on ${D} to make sure portage doesn't do any such thing
+ find "${Ddir}" -exec touch '{}' \;
+
+ make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
+ newicon ${CDROM_ROOT}/icon.xpm ${PN}.xpm
+
+ make_desktop_entry ${PN} "FAKK2" ${PN}
+}
+
+pkg_postinst() {
+ echo
+ ewarn "There are two possible security bugs in this package, both causing a denial of"
+ ewarn "service. One affects the game when running a server, the other when running as"
+ ewarn "a client. For more information, see bug #82149."
+ echo
+ elog "To play the game run:"
+ elog " fakk2"
+}
diff --git a/games-action/fakk2/metadata.xml b/games-action/fakk2/metadata.xml
new file mode 100644
index 000000000000..07964f9113c6
--- /dev/null
+++ b/games-action/fakk2/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+Heavy Metal: F.A.K.K.2 is a third-person 3-D action game based on characters from the Heavy Metal comics and movies. Years have passed since Julie Strain (a.k.a. F.A.K.K.2) defeated the would-be God Lord Tyler on the bloody battlefields of the Holy Land. She has long since put the pain of those days behind her and brought her homeworld of Eden to a perfect natural balance. But far away in the deepest nebulas of space, the greatest evil of all stirs, ready to make its final move -- to take control of the entire universe. A lone beacon hurtles toward Eden, hoping to summon the god-slayer F.A.K.K.2 one last time. It bears nothing more than an onimous warning: "GITH IS COMING." The game was ported to Linux by the now defunct Loki Entertainment and is commercial software. You can still pick up a copy from Tuxgames (http://www.tuxgames.com), but supplies are limited, as the publisher is no longer in business.
+</longdescription>
+</pkgmetadata>