summaryrefslogtreecommitdiff
path: root/games-action/bzflag/files/bzflag-2.4.12-sdl2-cppflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/bzflag/files/bzflag-2.4.12-sdl2-cppflags.patch')
-rw-r--r--games-action/bzflag/files/bzflag-2.4.12-sdl2-cppflags.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/games-action/bzflag/files/bzflag-2.4.12-sdl2-cppflags.patch b/games-action/bzflag/files/bzflag-2.4.12-sdl2-cppflags.patch
new file mode 100644
index 000000000000..f7f6dfd7f14c
--- /dev/null
+++ b/games-action/bzflag/files/bzflag-2.4.12-sdl2-cppflags.patch
@@ -0,0 +1,19 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -236,6 +236,7 @@
+ AC_PROG_CC
+ AC_PROG_LN_S
+ AC_CHECK_PROG(AR, ar, ar)
++PKG_PROG_PKG_CONFIG
+ AC_SUBST(AR)
+ AC_SUBST(AR_FLAGS)
+
+@@ -716,6 +717,8 @@
+ fi
+ if test "x$with_SDL" = "x2"; then
+ AC_DEFINE(HAVE_SDL2, 1, [Using SDL2])
++ PKG_CHECK_MODULES(sdl2, sdl2,
++ [CONF_CPPFLAGS="$CONF_CPPFLAGS $sdl2_CFLAGS"],[])
+ fi
+
+ AM_CONDITIONAL(HAVE_SDL, test x$with_SDL = x1 -o x$with_SDL = x2)