summaryrefslogtreecommitdiff
path: root/games-action/barrage/barrage-1.0.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/barrage/barrage-1.0.4-r1.ebuild')
-rw-r--r--games-action/barrage/barrage-1.0.4-r1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/games-action/barrage/barrage-1.0.4-r1.ebuild b/games-action/barrage/barrage-1.0.4-r1.ebuild
index fc4dde6e54ed..3f7e63b9a76e 100644
--- a/games-action/barrage/barrage-1.0.4-r1.ebuild
+++ b/games-action/barrage/barrage-1.0.4-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils
+inherit desktop gnome2-utils
DESCRIPTION="A violent point-and-click shooting game"
HOMEPAGE="http://lgames.sourceforge.net/Barrage/"
@@ -26,3 +26,11 @@ src_install() {
make_desktop_entry ${PN} Barrage
rm "${ED%/}"/usr/share/applications/${PN}.desktop || die
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}