summaryrefslogtreecommitdiff
path: root/games-action/armagetronad/armagetronad-0.2.8.3.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/armagetronad/armagetronad-0.2.8.3.3-r1.ebuild')
-rw-r--r--games-action/armagetronad/armagetronad-0.2.8.3.3-r1.ebuild17
1 files changed, 6 insertions, 11 deletions
diff --git a/games-action/armagetronad/armagetronad-0.2.8.3.3-r1.ebuild b/games-action/armagetronad/armagetronad-0.2.8.3.3-r1.ebuild
index 7aa64769890a..9147b2111608 100644
--- a/games-action/armagetronad/armagetronad-0.2.8.3.3-r1.ebuild
+++ b/games-action/armagetronad/armagetronad-0.2.8.3.3-r1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit eutils gnome2-utils
DESCRIPTION="Fast-paced 3D lightcycle game based on Tron"
@@ -16,15 +17,12 @@ IUSE="dedicated sound"
RDEPEND="
dev-libs/libxml2
!dedicated? (
- media-libs/libpng:0
- media-libs/libsdl[X,opengl,video]
+ media-libs/libpng:0=
+ media-libs/libsdl[X,opengl,video,sound?]
media-libs/sdl-image[jpeg,png]
virtual/glu
virtual/opengl
- sound? (
- media-libs/libsdl[sound]
- media-libs/sdl-mixer
- )
+ sound? ( media-libs/sdl-mixer )
)"
DEPEND=${RDEPEND}
@@ -38,7 +36,6 @@ src_prepare() {
src_configure() {
# --enable-games just messes up paths
econf \
- --docdir=/usr/share/doc/${PF} \
$(use_enable dedicated) \
$(use_enable sound music) \
--disable-sysinstall \
@@ -48,12 +45,10 @@ src_configure() {
}
src_install() {
- # FIXME: is the -j1 needed? https://bugs.gentoo.org/588104
- emake -j1 DESTDIR="${D}" install
- einstalldocs
+ default
# misplaced desktop-file/icons
- rm -rf "${ED%/}${GAMES_DATADIR}"/armagetronad/desktop
+ rm -r "${ED%/}"/usr/share/${PN}/desktop || die
doicon -s 48 desktop/icons/large/armagetronad.png
make_desktop_entry ${PN}
}