summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin37807 -> 37642 bytes
-rw-r--r--eclass/apache-2.eclass2
-rw-r--r--eclass/gstreamer-meson.eclass10
-rw-r--r--eclass/llvm.org.eclass3
-rw-r--r--eclass/meson.eclass3
-rw-r--r--eclass/sword-module.eclass96
-rw-r--r--eclass/toolchain-funcs.eclass14
-rw-r--r--eclass/usr-ldscript.eclass4
-rw-r--r--eclass/xorg-3.eclass23
9 files changed, 23 insertions, 132 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index eb2e0670a634..2de9671d1c46 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/apache-2.eclass b/eclass/apache-2.eclass
index 3dc3b3e56db0..5ff17fd8d228 100644
--- a/eclass/apache-2.eclass
+++ b/eclass/apache-2.eclass
@@ -476,7 +476,7 @@ apache-2_src_prepare() {
# 03_all_gentoo-apache-tools.patch injects -Wl,-z,now, which is not a good
# idea for everyone
case ${CHOST} in
- *-linux-gnu|*-solaris*|*-freebsd*)
+ *-linux-gnu|*-solaris*)
# do nothing, these use GNU binutils
:
;;
diff --git a/eclass/gstreamer-meson.eclass b/eclass/gstreamer-meson.eclass
index 570254270e6d..96ab97f3767b 100644
--- a/eclass/gstreamer-meson.eclass
+++ b/eclass/gstreamer-meson.eclass
@@ -88,6 +88,16 @@ opencv"
GST_PLUGINS_EXT_DEPS="${GST_PLUGINS_EXT_DEPS}
hls"
fi
+
+ # See bug #907483
+ if grep -q "option('qt5'" "${EMESON_SOURCE}"/meson_options.txt ; then
+ GST_PLUGINS_EXT_DEPS="${GST_PLUGINS_EXT_DEPS}
+qt5"
+ fi
+ if grep -q "option('qt6'" "${EMESON_SOURCE}"/meson_options.txt ; then
+ GST_PLUGINS_EXT_DEPS="${GST_PLUGINS_EXT_DEPS}
+qt6"
+ fi
}
# @FUNCTION: gstreamer_system_package
diff --git a/eclass/llvm.org.eclass b/eclass/llvm.org.eclass
index c5bdc7d1d8be..1fb544094d4a 100644
--- a/eclass/llvm.org.eclass
+++ b/eclass/llvm.org.eclass
@@ -72,6 +72,9 @@ if [[ -z ${_LLVM_SOURCE_TYPE+1} ]]; then
_LLVM_SOURCE_TYPE=snapshot
case ${PV} in
+ 17.0.0_pre20230609)
+ EGIT_COMMIT=62c0bdabfa32f6e32b17b45425b15309db340dfb
+ ;;
17.0.0_pre20230602)
EGIT_COMMIT=f9753ef1893c3d953a0244e7935d3997499b079a
;;
diff --git a/eclass/meson.eclass b/eclass/meson.eclass
index 4dfa08ba5553..2c274b213191 100644
--- a/eclass/meson.eclass
+++ b/eclass/meson.eclass
@@ -112,10 +112,7 @@ _meson_get_machine_info() {
# system roughly corresponds to uname -s (lowercase)
case ${tuple} in
- *-aix*) system=aix ;;
- *-cygwin*) system=cygwin ;;
*-darwin*) system=darwin ;;
- *-freebsd*) system=freebsd ;;
*-linux*) system=linux ;;
mingw*|*-mingw*) system=windows ;;
*-solaris*) system=sunos ;;
diff --git a/eclass/sword-module.eclass b/eclass/sword-module.eclass
deleted file mode 100644
index be3725a6ec55..000000000000
--- a/eclass/sword-module.eclass
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# @DEAD
-# @ECLASS: sword-module.eclass
-# @MAINTAINER:
-# Marek Szuba <marecki@gentoo.org>
-# @SUPPORTED_EAPIS: 7 8
-# @BLURB: Simplify installation of SWORD modules
-# @DESCRIPTION:
-# This eclass provides dependencies, ebuild environment and the src_install
-# function common to all app-text/sword modules published by the SWORD Project.
-#
-# Note that as of 2021-06-16 module archives published by SWORD are still
-# not versioned and it is necessary to look at respective module pages in
-# order to see what versions the currently available files are. Once
-# a module file has been replicated to the Gentoo mirror network it will be
-# versioned and remain available even after upstream has changed their
-# version, however users not using mirrors will encounter hash conflicts
-# on updated modules. Should that happen, please notify the relevant
-# package maintainers that a new version is available.
-#
-# @EXAMPLE:
-# sword-Personal-1.0.ebuild, a typical ebuild using sword-module.eclass:
-#
-# @CODE
-# EAPI=8
-#
-# SWORD_MINIMUM_VERSION="1.5.1a"
-#
-# inherit sword-module
-#
-# DESCRIPTION="SWORD module for storing one's own commentary"
-# HOMEPAGE="https://crosswire.org/sword/modules/ModInfo.jsp?modName=Personal"
-# LICENSE="public-domain"
-# KEYWORDS="~amd64 ~ppc ~x86"
-#
-# @CODE
-
-case ${EAPI:-0} in
- 0|1|2|3|4|5|6)
- die "Unsupported EAPI=${EAPI} (too old) for ${ECLASS}"
- ;;
- 7|8)
- ;;
- *)
- die "Unsupported EAPI=${EAPI} (unknown) for ${ECLASS}"
- ;;
-esac
-
-# @ECLASS_VARIABLE: SWORD_MINIMUM_VERSION
-# @DEFAULT_UNSET
-# @PRE_INHERIT
-# @DESCRIPTION:
-# If set to a non-null value, specifies the minimum version of app-text/sword
-# the module requires. This will be included in RDEPEND. If null or unset,
-# the dependency will be unversioned.
-# Needs to be set before the inherit line.
-
-# @ECLASS_VARIABLE: SWORD_MODULE
-# @PRE_INHERIT
-# @DESCRIPTION:
-# Case-sensitive name of the SWORD-Project module to install. If unset
-# or null, use the name produced by removing the prefix 'sword-' from PN.
-# Needs to be set before the inherit line.
-: ${SWORD_MODULE:=${PN#sword-}}
-
-EXPORT_FUNCTIONS src_install
-
-# Unless overridden at ebuild level, append version to the name of the file
-# fetched from upstream and let the Gentoo mirror network take care of
-# persisting the versioned archive.
-SRC_URI="https://crosswire.org/ftpmirror/pub/sword/packages/rawzip/${SWORD_MODULE}.zip -> ${SWORD_MODULE}-${PV}.zip"
-
-SLOT="0"
-
-# Module archives contain no top-level directory.
-S="${WORKDIR}"
-
-if [[ ${SWORD_MINIMUM_VERSION} ]]; then
- RDEPEND=">=app-text/sword-${SWORD_MINIMUM_VERSION}"
-else
- RDEPEND="app-text/sword"
-fi
-
-BDEPEND="app-arch/unzip"
-
-# @FUNCTION: sword-module_src_install
-# @DESCRIPTION:
-# Install all the module files into directories used by app-text/sword.
-sword-module_src_install() {
- insinto /usr/share/sword/modules
- doins -r modules/*
- insinto /usr/share/sword/mods.d
- doins mods.d/*
-}
diff --git a/eclass/toolchain-funcs.eclass b/eclass/toolchain-funcs.eclass
index 63db0cfa5e0e..bffbf36f1696 100644
--- a/eclass/toolchain-funcs.eclass
+++ b/eclass/toolchain-funcs.eclass
@@ -683,16 +683,7 @@ tc-ninja_magic_to_arch() {
frv*) echo frv;;
hexagon*) echo hexagon;;
hppa*) ninj parisc hppa;;
- i?86*)
- # Starting with linux-2.6.24, the 'x86_64' and 'i386'
- # trees have been unified into 'x86'.
- # FreeBSD still uses i386
- if [[ ${type} == "kern" && ${host} == *freebsd* ]] ; then
- echo i386
- else
- echo x86
- fi
- ;;
+ i?86*) echo x86;;
ia64*) echo ia64;;
loongarch*) ninj loongarch loong;;
m68*) echo m68k;;
@@ -726,7 +717,6 @@ tc-ninja_magic_to_arch() {
;;
tile*) echo tile;;
vax*) echo vax;;
- x86_64*freebsd*) echo amd64;;
x86_64*)
# Starting with linux-2.6.24, the 'x86_64' and 'i386'
# trees have been unified into 'x86'.
@@ -1077,7 +1067,7 @@ gen_usr_ldscript() {
case ${CTARGET:-${CHOST}} in
*-darwin*) ;;
*-android*) return 0 ;;
- *linux*|*-freebsd*|*-openbsd*|*-netbsd*)
+ *linux*)
use prefix && return 0 ;;
*) return 0 ;;
esac
diff --git a/eclass/usr-ldscript.eclass b/eclass/usr-ldscript.eclass
index 6dbce59c6400..e52de9e658d4 100644
--- a/eclass/usr-ldscript.eclass
+++ b/eclass/usr-ldscript.eclass
@@ -1,4 +1,4 @@
-# Copyright 2019-2022 Gentoo Authors
+# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: usr-ldscript.eclass
@@ -55,7 +55,7 @@ gen_usr_ldscript() {
case ${CTARGET:-${CHOST}} in
*-darwin*) ;;
*-android*) return 0 ;;
- *linux*|*-freebsd*|*-openbsd*|*-netbsd*)
+ *linux*)
use split-usr || return 0
;;
*) return 0 ;;
diff --git a/eclass/xorg-3.eclass b/eclass/xorg-3.eclass
index c3ece64ae42d..e0b26acca0b0 100644
--- a/eclass/xorg-3.eclass
+++ b/eclass/xorg-3.eclass
@@ -273,21 +273,11 @@ xorg-3_src_unpack() {
xorg-3_reconf_source() {
debug-print-function ${FUNCNAME} "$@"
- case ${CHOST} in
- *-aix* | *-winnt*)
- # some hosts need full eautoreconf
- [[ -e "./configure.ac" || -e "./configure.in" ]] \
- && XORG_EAUTORECONF=yes
- ;;
- *)
- # elibtoolize required for BSD
- [[ ${XORG_EAUTORECONF} != no && ( -e "./configure.ac" || -e "./configure.in" ) ]] \
- && XORG_EAUTORECONF=yes
- ;;
- esac
-
- [[ ${XORG_EAUTORECONF} != no ]] && eautoreconf
- elibtoolize --patch-only
+ if [[ ${XORG_EAUTORECONF} != no ]] ; then
+ eautoreconf
+ else
+ elibtoolize --patch-only
+ fi
}
# @FUNCTION: xorg-3_src_prepare
@@ -326,9 +316,6 @@ xorg-3_font_configure() {
xorg-3_flags_setup() {
debug-print-function ${FUNCNAME} "$@"
- # Win32 require special define
- [[ ${CHOST} == *-winnt* ]] && append-cppflags -DWIN32 -D__STDC__
-
# Hardened flags break module autoloading et al (also fixes #778494)
if [[ ${PN} == xorg-server || ${PN} == xf86-video-* || ${PN} == xf86-input-* ]]; then
filter-flags -fno-plt