summaryrefslogtreecommitdiff
path: root/eclass/qt6-build.eclass
diff options
context:
space:
mode:
Diffstat (limited to 'eclass/qt6-build.eclass')
-rw-r--r--eclass/qt6-build.eclass6
1 files changed, 6 insertions, 0 deletions
diff --git a/eclass/qt6-build.eclass b/eclass/qt6-build.eclass
index 11e9844346a4..0b4ea6a58ce6 100644
--- a/eclass/qt6-build.eclass
+++ b/eclass/qt6-build.eclass
@@ -98,6 +98,12 @@ qt6-build_src_unpack() {
qt6-build_src_prepare() {
cmake_src_prepare
+ if [[ -e CMakeLists.txt ]]; then
+ # build may be skipped entirely and install nothing without errors
+ # if checking for a major dependency/condition failed
+ sed -i '/message(NOTICE.*Skipping/s/NOTICE/FATAL_ERROR/' CMakeLists.txt || die
+ fi
+
if in_iuse test && use test && [[ -e tests/auto/CMakeLists.txt ]]; then
# upstream seems to install before running tests, and cmake
# subdir that is present in about half of the Qt6 components