summaryrefslogtreecommitdiff
path: root/dev-vcs
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/Manifest.gzbin11331 -> 11331 bytes
-rw-r--r--dev-vcs/pre-commit/Manifest2
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.0.2.ebuild56
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-vcs/Manifest.gz b/dev-vcs/Manifest.gz
index 44971604dba1..3d87dea23274 100644
--- a/dev-vcs/Manifest.gz
+++ b/dev-vcs/Manifest.gz
Binary files differ
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index e530afab294f..368c33e2a2fb 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,5 +1,7 @@
AUX pre-commit-2.20.0-no_toml.patch 2448 BLAKE2B 1f067b87826fe582b4b9afaf235ec25ff53eefb5b05b28edcc477c9a697e223df0bcda3330afc6ed868c5cdf0ca836da53c884901039c05a7cbd06cbd9e8e2a7 SHA512 7fbd1dcc0fae28d8265827def2ed73eccc65791912e6bd410c457d4c437a385991af9675107634be319ba5fe1521af3309d29f49e2bcc6dcdc091a2a28925beb
AUX pre-commit-2.20.0-tests_git_file_transport.patch 2021 BLAKE2B 764b353d3268176162ae2a5d6fc97c0cb9ad7d2cd5de69f19f8fcd78c8bba507f25f53cd3d6c767fbcb9b9f885f8eceda2fc82d1b6ed54f34c1d4907d0fddd72 SHA512 6d8a3b5c9026f5c20a84d581ca92d74743643de010af468217b2f44324560d56b504e033ccebe102194492b25a01a4ed503995c222561ce406577fce211c2eab
DIST pre-commit-2.20.0.gh.tar.gz 266604 BLAKE2B 470f032e6d5bfcdd9ac8ba8f37d4323b601da0c82bcd524ffc575dc688fe81ad326a1f6a8ddd03da6e37130319ee40070c03d9789cd6e0e4b427a1d6e646416e SHA512 b1da558a0e5d8f2f655427089f1d0b11b01ad7513ece7a0b3b67c33529cf3584edba558c78704e6da6ca18876b1d6c0fa8698e01fd7c2439b8d4dc0a93961e52
+DIST pre-commit-3.0.2.gh.tar.gz 265956 BLAKE2B fd579de75531f8ee369ce304213baa609280546fcbb2a3fb144e298ce5a1205905c3dfcba7d0f01c47f73bbcaf67678f8cde414a45f6c0dbcdbcc5fd3a7589d2 SHA512 58350fb33663c8c671b187e81840b19e5e33bd50ed65d0e67b814ce619c7df63f4fad7f66ebd86829bd854522460d451de6071a9d548b0a4bbd538609e41cc72
EBUILD pre-commit-2.20.0-r1.ebuild 1752 BLAKE2B 92c0729e7ab388bcd1d3e37a5f7201deb99a7e966c6858757ab53ca3c1fe518af1b3163b195d7a67f6e14fd03eaae23e7d9f08eb76e5eac07b350102ca9c1fea SHA512 9fe82ca436aa4bc482a2ed6772acd86db1ddbd1931e1fb170e3b4664a17b60afdba5dd524deef18937d95329155a9a48b50e1ec75853d159f9f847d6b7375195
+EBUILD pre-commit-3.0.2.ebuild 1713 BLAKE2B ab2caef14c49a15079f3fc02956abb3c973d0ed168f6d231befd780921dbb1541d791313bd5b999850db072a53ffd963c3686b8cbf845caa650e6804c6b8cefd SHA512 0060581011dbd0e85e86dea57e29c8e9db2187ed70a9fe226bdf9f220f56c9e1c065a76d9471e6590abf50d9e234cbc54ee873075868aeec6438edc8c78c9ab5
MISC metadata.xml 380 BLAKE2B 99842a97367e91700c6f714f427b7b3d4b7212c401abae5ab715dfaa724776f02fe250184a33504d3433bb58cd5679af59a32ec21a7e7432481160dab36a4d95 SHA512 45330930d1e58fc1de0fd0ba55cd488dee96579ceab3be5073b91ff8f4f2b9adefff533dbfa5b0e8b23fbb648d45c0b7b4073a1ec57b586600cc2bf6347e0bbb
diff --git a/dev-vcs/pre-commit/pre-commit-3.0.2.ebuild b/dev-vcs/pre-commit/pre-commit-3.0.2.ebuild
new file mode 100644
index 000000000000..5a0641fc9c02
--- /dev/null
+++ b/dev-vcs/pre-commit/pre-commit-3.0.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
+HOMEPAGE="https://pre-commit.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-vcs/git
+ $(python_gen_cond_dep '
+ >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
+ ')"
+# coreutils requirement: see Bug #885559
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
+ sys-apps/coreutils[-multicall]
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.20.0-tests_git_file_transport.patch
+)
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
+# and while some of them do include "skip if not found" logic, most of them do not.
+# The latter consistently fail with
+# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
+# including with the sandbox disabled and when run manually with tox.
+EPYTEST_DESELECT=(
+ tests/languages/
+ tests/repository_test.py
+ tests/main_test.py::test_all_cmds
+ tests/main_test.py::test_try_repo
+)
+
+distutils_enable_tests pytest